summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2021-05-26 16:35:25 +0200
committerRoel Janssen <roel@gnu.org>2021-05-26 16:35:25 +0200
commit315472eddd8281a5678c9e5f6fc3ae8afeb97739 (patch)
treed941d557fc5787d2e33183eb4b2583da16c63ce9
parent64eda9c881b9d7008ae562dbcd5718ae8cb1a797 (diff)
downloadguix-patches-315472eddd8281a5678c9e5f6fc3ae8afeb97739.tar
guix-patches-315472eddd8281a5678c9e5f6fc3ae8afeb97739.tar.gz
gnu: Add r-heatmap3.
* gnu/packages/cran.scm (r-heatmap3): New variable.
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6405a2d5f9..db7f7f01e3 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6396,6 +6396,30 @@ fixed values. Other functions include a custom @code{geom}, and helper
functions to enforce symmetric scales or add tags to facetted plots.")
(license license:gpl3)))
+(define-public r-heatmap3
+ (package
+ (name "r-heatmap3")
+ (version "1.1.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "heatmap3" version))
+ (sha256
+ (base32
+ "0sfvizmmwfk1bjhn6zfx5a4qqfgj1ldg8x90b65crqibgfa36k2r"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-fastcluster" ,r-fastcluster)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://cran.r-project.org/web/packages/heatmap3/")
+ (synopsis "Improved heatmap package")
+ (description
+ "This package provides an improved heatmap package. It is completely
+compatible with the original R function @code{heatmap}, and provides more
+powerful and convenient features.")
+ (license license:gpl2+)))
+
(define-public r-heatmaply
(package
(name "r-heatmaply")