summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-11 11:00:10 -0500
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 15:43:38 -0400
commit2539bc5cab368ad98fdc88ccb77a8a790bbb8cde (patch)
treecc0dae7334c7a5b6d7cc66c47a02b91de493a033
parentf14578c364c506a020c1b42339c4324c359ca149 (diff)
downloadguix-patches-2539bc5cab368ad98fdc88ccb77a8a790bbb8cde.tar
guix-patches-2539bc5cab368ad98fdc88ccb77a8a790bbb8cde.tar.gz
gnu: gdk-pixbuf: Disable failing tests.
* gnu/packages/gtk.scm (gdk-pixbuf) [arguments]<#:phases>['disable-failing-tests]: New phase. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
-rw-r--r--gnu/packages/gtk.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 78a031ce72..c97bc66acb 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -608,6 +608,12 @@ highlighting and other features typical of a source code editor.")
(string-append (assoc-ref inputs "docbook-xml")
"/xml/dtd/docbook/"))))
#t))
+ (add-before 'configure 'disable-failing-tests
+ (lambda _
+ (substitute* "tests/meson.build"
+ (("\\[ 'pixbuf-fail', \\['conform', 'slow'\\], \\],")
+ ""))
+ #t))
;; The slow tests take longer than the specified timeout.
,@(if (any (cute string=? <> (%current-system))
'("armhf-linux" "aarch64-linux"))