summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-12 08:32:10 -0500
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 16:35:04 -0400
commit0f9355c06cf684143e56d9c86f6d2b10bd15c325 (patch)
tree1558e589575b30285d66bdf429be4af8fbc0c331
parent5721c0f03de384e59504f4083ca73315b3ea6b34 (diff)
downloadguix-patches-0f9355c06cf684143e56d9c86f6d2b10bd15c325.tar
guix-patches-0f9355c06cf684143e56d9c86f6d2b10bd15c325.tar.gz
gnu: gtk+: Add missing inputs.
* gnu/packages/gtk.scm (gtk+) [native-inputs]: Add docbook-xml, hicolor-icon-theme, intltool, sassc and libxslt. [inputs]: Add graphene, harfbuzz, iso-codes and papi. [propagated-inputs]: Add cairo, fribidi, fontconfig, freetype, glib, libx11, libxcomposite, libxext, libxfixes and libxrender. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
-rw-r--r--gnu/packages/gtk.scm48
1 files changed, 35 insertions, 13 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 74fd5ceb8e..fcc20884fe 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -77,6 +77,7 @@
#:use-module (gnu packages graphviz)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages image)
+ #:use-module (gnu packages iso-codes)
#:use-module (gnu packages libffi)
#:use-module (gnu packages linux)
#:use-module (gnu packages m4)
@@ -85,12 +86,14 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pretty-print)
+ #:use-module (gnu packages profiling)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages guile)
#:use-module (gnu packages guile-xyz)
#:use-module (gnu packages cups)
#:use-module (gnu packages version-control)
+ #:use-module (gnu packages web)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
#:use-module (gnu packages xdisorg)
@@ -939,44 +942,63 @@ application suites.")
(patches (search-patches "gtk3-respect-GUIX_GTK3_PATH.patch"
"gtk3-respect-GUIX_GTK3_IM_MODULE_FILE.patch"))))
(propagated-inputs
- `(("at-spi2-atk" ,at-spi2-atk)
- ("atk" ,atk)
+ `(("atk" ,atk)
+ ("at-spi2-atk" ,at-spi2-atk)
+ ("cairo" ,cairo)
+ ("fribidi" ,fribidi)
+ ("fontconfig" ,fontconfig)
+ ("freetype" ,freetype)
;; SVG support is optional and requires librsvg, which pulls in rust.
;; Rust is not supported well on every architecture yet.
("gdk-pixbuf" ,(if (string-prefix? "x86_64" (or (%current-target-system)
(%current-system)))
gdk-pixbuf+svg
gdk-pixbuf))
+ ("glib" ,glib)
("libepoxy" ,libepoxy)
+ ("libx11" ,libx11)
+ ("libxcomposite" ,libxcomposite)
("libxcursor" ,libxcursor)
+ ("libxdamage" ,libxdamage)
+ ("libxext" ,libxext)
+ ("libxfixes" ,libxfixes)
("libxi" ,libxi)
("libxinerama" ,libxinerama)
("libxkbcommon" ,libxkbcommon)
- ("libxdamage" ,libxdamage)
("libxrandr" ,libxrandr)
+ ("libxrender" ,libxrender)
("mesa" ,mesa)
("pango" ,pango)
("wayland" ,wayland)
("wayland-protocols" ,wayland-protocols)))
(inputs
- `(("libxml2" ,libxml2)
- ;; XXX: colord depends on mozjs (through polkit), which fails on
+ `(;; XXX: colord depends on mozjs (through polkit), which fails on
;; on non-intel systems now.
- ;;("colord" ,colord)
- ("cups" ,cups) ;for printing support
+ ("colord" ,colord)
+ ("cups" ,cups)
+ ("graphene" ,graphene)
+ ("harfbuzz" ,harfbuzz)
+ ("iso-codes" ,iso-codes)
+ ("json-glib" ,json-glib)
+ ("libxml2" ,libxml2)
+ ("papi" ,papi)
;; XXX: rest depends on p11-kit, which fails on mips64el now.
- ;;("rest" ,rest)
- ("json-glib" ,json-glib)))
+ ("rest" ,rest)))
(native-inputs
- `(("perl" ,perl)
- ("glib" ,glib "bin")
+ `(("docbook-xml" ,docbook-xml-4.1.2)
("gettext" ,gettext-minimal)
- ("pkg-config" ,pkg-config)
+ ("glib" ,glib "bin")
("gobject-introspection" ,gobject-introspection)
+ ("hicolor-icon-theme" ,hicolor-icon-theme)
+ ("intltool" ,intltool)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
("python-wrapper" ,python-wrapper)
+ ("sassc" ,sassc)
;; By using a special xorg-server for GTK+'s tests, we reduce the impact
;; of updating xorg-server directly on the master branch.
- ("xorg-server" ,xorg-server-for-tests)))
+ ("xorg-server" ,xorg-server-for-tests)
+ ("xsltproc" ,libxslt)))
(arguments
`(#:disallowed-references (,xorg-server-for-tests)
;; 47 MiB goes to "out" (24 of which is locale data!), and 26 MiB goes