summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-07 10:59:29 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-07 11:00:33 +0100
commitd7368fe7f2f9616f123ce059ddc576fe7124ea97 (patch)
tree4466e46aec8bce04761b1dfd6046bf5740ccc744
parentfb3508bb36baac17c17fee948becd824e784e8ba (diff)
downloadguix-patches-d7368fe7f2f9616f123ce059ddc576fe7124ea97.tar
guix-patches-d7368fe7f2f9616f123ce059ddc576fe7124ea97.tar.gz
gnu: notmuch: Use G-expressions.
* gnu/packages/mail.scm (notmuch)[arguments]: Use G-expressions. <#:phases>: Use SEARCH-INPUT-FILES instead of WHICH.
-rw-r--r--gnu/packages/mail.scm38
1 files changed, 20 insertions, 18 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 9c8fa0ee36..0c2bd8f715 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1345,24 +1345,26 @@ invoking @command{notifymuch} from the post-new hook.")
(base32 "0fdc81m24xrbhfrhw00g12ak4b8hap4961sq7ap6q2pjqhac8cd8"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags
- (list "V=1" ; verbose test output
- "NOTMUCH_TEST_TIMEOUT=1h") ; don't fail on slow machines
- #:phases (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (setenv "CC" ,(cc-for-target))
- (setenv "CONFIG_SHELL" (which "sh"))
- (let* ((out (assoc-ref outputs "out")))
- (invoke "./configure"
- (string-append "--prefix=" out)
- "--without-emacs"))))
- (add-before 'check 'prepare-test-environment
- (lambda _
- (setenv "TEST_CC" ,(cc-for-target))
- ;; Patch various inline shell invocations.
- (substitute* (find-files "test" "\\.sh$")
- (("/bin/sh") (which "sh"))))))))
+ (list
+ #:make-flags
+ #~(list "V=1" ; verbose test output
+ "NOTMUCH_TEST_TIMEOUT=1h") ; don't fail on slow machines
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "CC" #$(cc-for-target))
+ (setenv "CONFIG_SHELL" (search-input-file inputs "/bin/sh"))
+ (invoke "./configure"
+ (string-append "--prefix=" #$output)
+ "--without-emacs")))
+ (add-before 'check 'prepare-test-environment
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "TEST_CC" #$(cc-for-target))
+ ;; Patch various inline shell invocations.
+ (let ((sh (search-input-file inputs "/bin/sh")))
+ (substitute* (find-files "test" "\\.sh$")
+ (("/bin/sh") sh))))))))
(native-inputs
(list bash-completion
pkg-config