summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNiklas Eklund <niklas.eklund@posteo.net>2022-02-08 00:35:28 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-08 00:35:28 +0100
commitc7885577523567c10e3120a61c711ac7007f2ace (patch)
treef856dae5aa86a8097d8acdf4f09f64af004049ad
parent64c599c9a33e83d64609a8791fcd8685fc1b9b61 (diff)
downloadguix-patches-c7885577523567c10e3120a61c711ac7007f2ace.tar
guix-patches-c7885577523567c10e3120a61c711ac7007f2ace.tar.gz
gnu: Add emacs-popper.
* gnu/packages/emacs-xyz.scm (emacs-popper): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bec613e381..5395626493 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7292,6 +7292,30 @@ and popup menus.")
autocomplete style popup menu.")
(license license:gpl3+))))
+(define-public emacs-popper
+ ;; No tagged release upstream for version 0.45. The commit below matches
+ ;; version bump.
+ (let ((commit "851d83882192ac9599ac5b053614a42d683b3fab"))
+ (package
+ (name "emacs-popper")
+ (version "0.45")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/karthink/popper")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pk5wzqlz7n6v8rb1957i3ql0wjx578l68a3rp2m9pxr7a8a03h4"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/karthink/popper")
+ (synopsis "Emacs minor-mode to summon and dismiss buffers easily")
+ (description
+ "Popper is a minor-mode to tame the flood of ephemeral
+windows Emacs produces, while still keeping them within arm’s reach.")
+ (license license:gpl3+))))
+
(define-public emacs-python-black
(package
(name "emacs-python-black")