summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJai Vetrivelan <jaivetrivelan@gmail.com>2022-02-08 05:18:08 +0530
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-08 01:03:06 +0100
commit3610927bc020c65a6daaa40876df0bdd4df814c8 (patch)
treee5da81a0e7a69da719616eb76bc7d5f92da3407e
parentcd6879cf97000ee4ee554273b12d25f8bee27b66 (diff)
downloadguix-patches-3610927bc020c65a6daaa40876df0bdd4df814c8.tar
guix-patches-3610927bc020c65a6daaa40876df0bdd4df814c8.tar.gz
gnu: Add emacs-volatile-highlights.
* gnu/packages/emacs-xyz.scm (emacs-volatile-highlights): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5395626493..879eaffa23 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -30336,6 +30336,30 @@ which sends the current buffer to the World Wide Web Consortium’s HTML
Validator service and displays the results in a buffer in Compilation mode.")
(license license:gpl3+))))
+(define-public emacs-volatile-highlights
+ ;; XXX: Upstream does not tag releases. Commit below matches version bump.
+ (let ((commit "9a20091f0ce7fc0a6b3e641a6a46d5f3ac4d8392"))
+ (package
+ (name "emacs-volatile-highlights")
+ (version "1.15")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "http://github.com/k-talo/volatile-highlights.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1dsa6769lphyyv7yg92vkkpk395w52q4m7hdn8xy7s6lh5c6a955"))))
+ (build-system emacs-build-system)
+ (home-page "http://github.com/k-talo/volatile-highlights.el")
+ (synopsis "Emacs minor mode for visual feedback on some operations")
+ (description "@code{volatile-highlights-mode} brings visual feedback to
+some operations by highlighting portions relating to the operations. All of
+highlights made by this library will be removed when any new operation is
+executed.")
+ (license license:gpl3+))))
+
(define-public emacs-global-tags
(let ((commit "06db25d91cc8bfb5e24e02adc04de1226c7e742d")
(revision "0"))