summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-09-02 15:20:37 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-02-07 11:30:02 +0200
commit3344567bb14b8445495e402f0043dcf23f588242 (patch)
treee704ce611e7fe46c987f76d9c416f7d53a4e83fa
parent10abb0519033ca2218ade2f73ced312f1665306d (diff)
downloadguix-patches-3344567bb14b8445495e402f0043dcf23f588242.tar
guix-patches-3344567bb14b8445495e402f0043dcf23f588242.tar.gz
gnu: isc-dhcp: Fix building on riscv64-linux.
* gnu/packages/admin.scm (isc-dhcp)[arguments]: Add phase to update configure scripts. [inputs]: Add config.
-rw-r--r--gnu/packages/admin.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 17dc0f1315..f2ad66ea5b 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1220,6 +1220,21 @@ connection alive.")
;; build system uses the built 'gen' executable.
(setenv "BUILD_CC" "gcc"))))
'())
+ (add-before 'build 'update-config-scripts
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
+ (for-each (lambda (file)
+ (install-file
+ (search-input-file
+ (or native-inputs inputs)
+ (string-append "/bin/" file)) "."))
+ '("config.guess" "config.sub"))
+ (for-each (lambda (file)
+ (install-file
+ (search-input-file
+ (or native-inputs inputs)
+ (string-append "/bin/" file))
+ (string-append "bind/bind-" ,bind-version)))
+ '("config.guess" "config.sub"))))
(add-after 'configure 'post-configure
(lambda* (#:key outputs #:allow-other-keys)
;; Point to the right client script, which will be
@@ -1302,6 +1317,7 @@ connection alive.")
(base32
"108nh7hha4r0lb5hf1fn7lqaascvhsrghpz6afm5lf9vf2vgqly9"))))
+ ("config" ,config)
("coreutils*" ,coreutils)
("sed*" ,sed)))