summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-06-22 11:44:07 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-06-22 12:15:49 +0200
commit48713c5d94aa8b708517a961f75491e574645133 (patch)
treea9a1bf657f4c7b89175910fac3355c3ee30b1e12
parentb7f211bbbc1bde20252808a6fc68f56f5a9a0d5d (diff)
downloadguix-patches-48713c5d94aa8b708517a961f75491e574645133.tar
guix-patches-48713c5d94aa8b708517a961f75491e574645133.tar.gz
gnu: Add r-rlinsolve.
* gnu/packages/cran.scm (r-rlinsolve): New variable.
-rw-r--r--gnu/packages/cran.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f3c90b073e..2b5ccd13e2 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -21298,6 +21298,38 @@ Yue-Pilon's (Yue, 2002) pre-whitening approaches to determining trends in
climate data.")
(license license:lgpl2.1)))
+(define-public r-rlinsolve
+ (package
+ (name "r-rlinsolve")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "Rlinsolve" version))
+ (sha256
+ (base32
+ "1x02xxbkchcwwfa2123n9yqfzinfi0zba8zxhp977czzwysy75cc"))))
+ (properties `((upstream-name . "Rlinsolve")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-matrix" ,r-matrix)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rcpparmadillo" ,r-rcpparmadillo)
+ ("r-rdpack" ,r-rdpack)))
+ (home-page "https://cran.r-project.org/web/packages/Rlinsolve/")
+ (synopsis "Iterative solvers for (sparse) linear system of equations")
+ (description
+ "Solving a system of linear equations is one of the most fundamental
+computational problems for many fields of mathematical studies, such as
+regression problems from statistics or numerical partial differential
+equations. This package provides basic stationary iterative solvers such as
+Jacobi, Gauss-Seidel, Successive Over-Relaxation and SSOR methods.
+Nonstationary, also known as Krylov subspace methods are also provided.
+Sparse matrix computation is also supported in that solving large and sparse
+linear systems can be manageable using the @code{Matrix} package along with
+@code{RcppArmadillo}.")
+ (license license:gpl3+)))
+
(define-public r-zvcv
(package
(name "r-zvcv")