summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-28 12:46:49 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-01 11:54:04 -0500
commitf2b228010873a7b1be429293e0422560b6a805d5 (patch)
treecd5c37281054ed4d6beccb9e445ffb1116a5be6b
parente04cfc7bebcd3a27bb77eef4347729ca9d5e4b67 (diff)
downloadguix-patches-f2b228010873a7b1be429293e0422560b6a805d5.tar
guix-patches-f2b228010873a7b1be429293e0422560b6a805d5.tar.gz
gnu: meson-for-build: Remove package.
The meson-for-build package doesn't carry any special patch anymore; it appears to be obsolete. * gnu/packages/build-tools.scm (meson-for-build): Remove variable. * guix/build-system/meson.scm (default-meson): Use meson. * doc/guix.texi (Build Systems): Update doc.
-rw-r--r--doc/guix.texi14
-rw-r--r--gnu/packages/build-tools.scm10
-rw-r--r--guix/build-system/meson.scm2
3 files changed, 7 insertions, 19 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index 2347a77f4f..9221906225 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -7969,9 +7969,7 @@ implements the build procedure for packages that use
It adds both Meson and @uref{https://ninja-build.org/, Ninja} to the set
of inputs, and they can be changed with the parameters @code{#:meson}
-and @code{#:ninja} if needed. The default Meson is
-@code{meson-for-build}, which is special because it doesn't clear the
-@code{RUNPATH} of binaries and libraries when they are installed.
+and @code{#:ninja} if needed.
This build system is an extension of @code{gnu-build-system}, but with the
following phases changed to some specific for Meson:
@@ -8002,11 +8000,11 @@ Apart from that, the build system also adds the following phases:
@item fix-runpath
This phase ensures that all binaries can find the libraries they need.
-It searches for required libraries in subdirectories of the package being
-built, and adds those to @code{RUNPATH} where needed. It also removes
-references to libraries left over from the build phase by
-@code{meson-for-build}, such as test dependencies, that aren't actually
-required for the program to run.
+It searches for required libraries in subdirectories of the package
+being built, and adds those to @code{RUNPATH} where needed. It also
+removes references to libraries left over from the build phase by
+@code{meson}, such as test dependencies, that aren't actually required
+for the program to run.
@item glib-or-gtk-wrap
This phase is the phase provided by @code{glib-or-gtk-build-system}, and it
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index f75266508a..dc2411801c 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -263,16 +263,6 @@ resembles Python.")
(base32
"19cjy24mfaswxyvqmns6rd7hx05ybqb663zlgklspfr8l4jjmvbb"))))))
-(define-public meson-for-build
- (package
- (inherit meson)
- (name "meson-for-build")
- (source (origin
- (inherit (package-source meson))))
-
- ;; People should probably install "meson", not "meson-for-build".
- (properties `((hidden? . #t)))))
-
(define-public premake4
(package
(name "premake")
diff --git a/guix/build-system/meson.scm b/guix/build-system/meson.scm
index b68bcb80de..e04223381e 100644
--- a/guix/build-system/meson.scm
+++ b/guix/build-system/meson.scm
@@ -55,7 +55,7 @@
"Return the default meson package."
;; Lazily resolve the binding to avoid a circular dependency.
(let ((module (resolve-interface '(gnu packages build-tools))))
- (module-ref module 'meson-for-build)))
+ (module-ref module 'meson)))
(define* (lower name
#:key source inputs native-inputs outputs system target