summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-09-07 11:44:13 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-09-07 11:44:33 +0200
commitaf81591375ac5cc58fbf619a0eaa80a4245e1a00 (patch)
tree0f483543f6f13150c9f9b49f601ef00e579249de
parentec997158dbf10b2c3408ef5e48d650c0f6c85b21 (diff)
downloadguix-patches-af81591375ac5cc58fbf619a0eaa80a4245e1a00.tar
guix-patches-af81591375ac5cc58fbf619a0eaa80a4245e1a00.tar.gz
gnu: Add r-bgeecall.
* gnu/packages/bioconductor.scm (r-bgeecall): New variable.
-rw-r--r--gnu/packages/bioconductor.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index b2d687a5e6..6140d2987e 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -13766,6 +13766,42 @@ and can also be used to predict missing values in any other matrix containing
real numbers.")
(license license:gpl3)))
+(define-public r-bgeecall
+ (package
+ (name "r-bgeecall")
+ (version "1.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "BgeeCall" version))
+ (sha256
+ (base32
+ "1byciy7vzbdkdgaim10s9qb7zlxsywbhcsrka31gm0rm9ljqc665"))))
+ (properties `((upstream-name . "BgeeCall")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("kallisto" ,kallisto)
+ ("r-biomart" ,r-biomart)
+ ("r-biostrings" ,r-biostrings)
+ ("r-data-table" ,r-data-table)
+ ("r-dplyr" ,r-dplyr)
+ ("r-genomicfeatures" ,r-genomicfeatures)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-rhdf5" ,r-rhdf5)
+ ("r-rslurm" ,r-rslurm)
+ ("r-rtracklayer" ,r-rtracklayer)
+ ("r-sjmisc" ,r-sjmisc)
+ ("r-tximport" ,r-tximport)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/BgeeDB/BgeeCall")
+ (synopsis "RNA-Seq present/absent gene expression calls generation")
+ (description
+ "BgeeCall allows to generate present/absent gene expression calls without
+using an arbitrary cutoff like TPM<1. Calls are generated based on reference
+intergenic sequences. These sequences are generated based on expression of
+all RNA-Seq libraries of each species integrated in Bgee.")
+ (license license:gpl3)))
+
(define-public r-tximeta
(package
(name "r-tximeta")