summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-09-07 13:26:55 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-09-07 13:26:55 +0200
commit4506ef4286f2892ffec9e721efdb79ef3af35d0f (patch)
tree766f1dc7f89e1c5e279b8358e2db0cb7e5fbf268
parent9899f472e6bef9d6e37afed81c1ec995fc643557 (diff)
downloadguix-patches-4506ef4286f2892ffec9e721efdb79ef3af35d0f.tar
guix-patches-4506ef4286f2892ffec9e721efdb79ef3af35d0f.tar.gz
gnu: Add r-gam.
* gnu/packages/cran.scm (r-gam): New variable.
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 04d5c16b80..16310b6566 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9709,6 +9709,32 @@ cross-validated AUC estimates based on influence curves for i.i.d. and pooled
repeated measures data, respectively.")
(license license:asl2.0)))
+(define-public r-gam
+ (package
+ (name "r-gam")
+ (version "1.20")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "gam" version))
+ (sha256
+ (base32
+ "1zhy2fp7pxac8xp3z3hndhprj4s5gx3305b627vc78bal1ml3swi"))))
+ (properties `((upstream-name . "gam")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-foreach" ,r-foreach)))
+ (native-inputs
+ `(("gfortran" ,gfortran)))
+ (home-page "https://cran.r-project.org/package=gam")
+ (synopsis "Generalized additive models")
+ (description
+ "This package provides functions for fitting and working with generalized
+additive models, as described in chapter 7 of \"Statistical Models in
+S\" (Chambers and Hastie (eds), 1991), and \"Generalized Additive
+Models\" (Hastie and Tibshirani, 1990).")
+ (license license:gpl2)))
+
(define-public r-mosaiccore
(package
(name "r-mosaiccore")