summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-09-07 12:48:10 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-09-07 12:48:10 +0200
commit336e618770d9bb70e1595666c8d25b40936e83b5 (patch)
treeac7931c32142ebb79e28d4f8e76dc24a3167921e
parentaed1504837ee7a485db437d32526d68ff9a76825 (diff)
downloadguix-patches-336e618770d9bb70e1595666c8d25b40936e83b5.tar
guix-patches-336e618770d9bb70e1595666c8d25b40936e83b5.tar.gz
gnu: Add r-nsprcomp.
* gnu/packages/cran.scm (r-nsprcomp): New variable.
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 45d162dbfd..9319f971bd 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9390,6 +9390,33 @@ and make comparisons between different methodologies straightforward.")
several entropy estimators.")
(license license:gpl3+)))
+(define-public r-nsprcomp
+ (package
+ (name "r-nsprcomp")
+ (version "0.5.1-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "nsprcomp" version))
+ (sha256
+ (base32
+ "1zlc1ximx96f235c0l8qfs6vbp1kpnbf943wxsfahnnlnxvwi59f"))))
+ (properties `((upstream-name . "nsprcomp")))
+ (build-system r-build-system)
+ (home-page "https://sigg-iten.ch/research/")
+ (synopsis "Non-negative and sparse PCA")
+ (description
+ "This package implements two methods for performing a constrained
+principal component analysis (PCA), where non-negativity and/or sparsity
+constraints are enforced on the principal axes (PAs). The function
+@code{nsprcomp} computes one principal component (PC) after the other. Each
+PA is optimized such that the corresponding PC has maximum additional variance
+not explained by the previous components. In contrast, the function
+@code{nscumcomp} jointly computes all PCs such that the cumulative variance is
+maximal. Both functions have the same interface as the @code{prcomp} function
+from the @code{stats} package (plus some extra parameters).")
+ (license license:gpl2+)))
+
(define-public r-abcoptim
(package
(name "r-abcoptim")