summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-10-25 11:31:56 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-10-25 11:31:56 +0200
commit78a7c7f078177903f5d2ae53c544ecce8b4f14db (patch)
tree3b118bf2978421d13e5dd86596c22b3495d8dded
parentf3496c2b5c03606f72e5594af68f44460a30bb01 (diff)
downloadguix-patches-78a7c7f078177903f5d2ae53c544ecce8b4f14db.tar
guix-patches-78a7c7f078177903f5d2ae53c544ecce8b4f14db.tar.gz
gnu: python-pyqtgraph: Disable one failing test.
* gnu/packages/python-xyz.scm (python-pyqtgraph)[arguments]: Add test_reload to list of disabled tests.
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 14 insertions, 9 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ab05086143..771c373090 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14040,15 +14040,20 @@ ISO 8859, etc.).")
(lambda* (#:key inputs outputs #:allow-other-keys)
(add-installed-pythonpath inputs outputs)
(invoke "pytest" "-vv" "-k"
- ;; These tests try to download online data.
- (string-append "not test_PolyLineROI"
- " and not test_getArrayRegion_axisorder"
- " and not test_getArrayRegion"
- " and not test_PlotCurveItem"
- " and not test_NonUniformImage_colormap"
- " and not test_NonUniformImage_lut"
- " and not test_ImageItem_axisorder"
- " and not test_ImageItem")))))))
+ (string-append
+ ;; These tests try to download online data.
+ "not test_PolyLineROI"
+ " and not test_getArrayRegion_axisorder"
+ " and not test_getArrayRegion"
+ " and not test_PlotCurveItem"
+ " and not test_NonUniformImage_colormap"
+ " and not test_NonUniformImage_lut"
+ " and not test_ImageItem_axisorder"
+ " and not test_ImageItem"
+ ;; The test_reload test fails and suggests adding
+ ;; "--assert=plain" to the pytest command, but it
+ ;; doesn't solve the failure.
+ " and not test_reload")))))))
(native-inputs
`(("python-pytest" ,python-pytest)
("python-pytest-cov" ,python-pytest-cov)