summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-10-24 21:34:26 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-10-24 21:34:26 +0000
commit57c233b37b53a551ce359fed5542dc1ed2b5e75d (patch)
treea5bc83d1e0ee310992887534bfae7af9071edb38
parentda526f33f2563508ffc0eff2e35c9c15be29f29e (diff)
downloadguix-patches-57c233b37b53a551ce359fed5542dc1ed2b5e75d.tar
guix-patches-57c233b37b53a551ce359fed5542dc1ed2b5e75d.tar.gz
gnu: jellyfish: Remove Ruby bindings.
These bindings no longer build and we have no package that would need them. * gnu/packages/bioinformatics.scm (jellyfish)[outputs]: Remove "ruby" output. [arguments]: Remove option for building Ruby bindings. [native-inputs]: Remove ruby.
-rw-r--r--gnu/packages/bioinformatics.scm4
1 files changed, 0 insertions, 4 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index fc8b936d2a..f559d9cef7 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4712,13 +4712,10 @@ experiments and provide highly stable thresholds based on reproducibility.")
"0npa62wzasdibas5zp3n8j3armsci4kyvh0jw7jr0am4gg7vg5g1"))))
(build-system gnu-build-system)
(outputs '("out" ;for library
- "ruby" ;for Ruby bindings
"python")) ;for Python bindings
(arguments
`(#:configure-flags
(list "--without-sse" ; configure script probes for CPU features when SSE is enabled.
- (string-append "--enable-ruby-binding="
- (assoc-ref %outputs "ruby"))
(string-append "--enable-python-binding="
(assoc-ref %outputs "python")))
#:phases
@@ -4731,7 +4728,6 @@ experiments and provide highly stable thresholds based on reproducibility.")
(native-inputs
`(("bc" ,bc)
("time" ,time)
- ("ruby" ,ruby)
("python" ,python-wrapper)
("pkg-config" ,pkg-config)))
(inputs