summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-27 19:40:36 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-27 19:40:36 +0300
commit013c061ce55359a0f56599490ecd462243386df6 (patch)
tree43cbc739a55dd5cb6f5244e32713463f9e28a85e
parentee41859cc8fb2acc969813020a680523c26fe8a2 (diff)
downloadguix-patches-013c061ce55359a0f56599490ecd462243386df6.tar
guix-patches-013c061ce55359a0f56599490ecd462243386df6.tar.gz
gnu: python-asgiref: Honor #:tests? flag.
* gnu/packages/python-web.scm (python-asgiref)[arguments]: Adjust custom 'check phase to honor the #:tests? flag.
-rw-r--r--gnu/packages/python-web.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 444f04394e..55d27214ba 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -327,10 +327,12 @@ comes with a SOCKS proxy client.")
(base32 "1saqgpgbdvb8awzm0f0640j0im55hkrfzvcw683cgqw4ni3apwaf"))))
(build-system python-build-system)
(arguments
- '(#:phases (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "pytest" "-vv"))))))
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv")))))))
(native-inputs
`(("python-pytest" ,python-pytest)
("python-pytest-asyncio" ,python-pytest-asyncio)))