summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-08-12 11:54:19 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-08-12 13:57:10 +0200
commitdec2a0c9289fecbcdf963e46f036a2c01ac2d2a6 (patch)
tree0d3350545368a769ce9c3c8eaa9fcba7d1d75ceb
parent06d6de773baa1a167724e5519bdd2a4a3a1ca867 (diff)
downloadguix-patches-dec2a0c9289fecbcdf963e46f036a2c01ac2d2a6.tar
guix-patches-dec2a0c9289fecbcdf963e46f036a2c01ac2d2a6.tar.gz
gnu: Add r-cpp11.
* gnu/packages/cran.scm (r-cpp11): New variable.
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e62ce5feac..fe714d4a19 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22885,3 +22885,26 @@ Computation of @dfn{genetic relationship matrix} (GRM) and dominance matrix,
@dfn{linkage disequilibrium} (LD), and heritability with efficient algorithms
for linear mixed models (AIREML).")
(license license:gpl3)))
+
+(define-public r-cpp11
+ (package
+ (name "r-cpp11")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "cpp11" version))
+ (sha256
+ (base32
+ "1113y61lj4cg1d2yjavdx9zih5rzb4pnxmj5v3sr4bhzlxz2scda"))))
+ (properties `((upstream-name . "cpp11")))
+ (build-system r-build-system)
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/r-lib/cpp11")
+ (synopsis "C++11 Interface for R's C Interface")
+ (description
+ "This package provides a header only, C++11 interface to R's C interface.
+Compared to other approaches @code{cpp11} strives to be safe against long
+jumps from the C API as well as C++ exceptions, conform to normal R function
+semantics and supports interaction with @code{ALTREP} vectors.")
+ (license license:expat)))