summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-08-12 11:53:49 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-08-12 13:57:10 +0200
commit6fb37996018fe3fe93360cb9cb3c9255edb9f949 (patch)
tree024759803faca3d4c1de322a4cfd2c0c4ea44267
parente1bf91c396f134c6f924107ace97d7914a5dd733 (diff)
downloadguix-patches-6fb37996018fe3fe93360cb9cb3c9255edb9f949.tar
guix-patches-6fb37996018fe3fe93360cb9cb3c9255edb9f949.tar.gz
gnu: Add r-spatstat-data.
* gnu/packages/cran.scm (r-spatstat-data): New variable.
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index fa4825d62a..ad3c642263 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22795,3 +22795,26 @@ diagonals. This package allows you to compute the tensor product of arrays.")
"This package contains utility functions for the @code{spatstat} package
which may also be useful for other purposes.")
(license license:gpl2+)))
+
+(define-public r-spatstat-data
+ (package
+ (name "r-spatstat-data")
+ (version "1.4-3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "spatstat.data" version))
+ (sha256
+ (base32
+ "18lfj5vkwxgf5w9qz0g5al3zy8y2yi3bnd13w24hszfc82nbcmc9"))))
+ (properties `((upstream-name . "spatstat.data")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-matrix" ,r-matrix)
+ ("r-spatstat-utils" ,r-spatstat-utils)))
+ (home-page "http://www.spatstat.org")
+ (synopsis "Datasets for spatstat")
+ (description
+ "This package contains all the datasets for the @code{spatstat}
+package.")
+ (license license:gpl2+)))