summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-15 21:55:57 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-24 20:44:31 +0100
commitfb7686a9999109fa478c8a2f115e7e65c5e166d7 (patch)
treedf363dfbe6db683099fbe8d06af09990076070de
parent87a49025e9c6dec06f12df5f382fed5bf8906789 (diff)
downloadguix-patches-fb7686a9999109fa478c8a2f115e7e65c5e166d7.tar
guix-patches-fb7686a9999109fa478c8a2f115e7e65c5e166d7.tar.gz
gnu: python-flake8: Update to 3.7.9.
* gnu/packages/python-xyz.scm (python-flake8): Update to 3.7.9. [native-inputs]: Remove PYTHON-PYTEST-RUNNER.
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5713bb359b..a0cc69d084 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6535,13 +6535,13 @@ complexity of Python source code.")
(define-public python-flake8
(package
(name "python-flake8")
- (version "3.7.7")
+ (version "3.7.9")
(source (origin
(method url-fetch)
(uri (pypi-uri "flake8" version))
(sha256
(base32
- "0qg6zggqigrd4k3gv88shd1a27d0cwgfql8vfiq2c7rl7w3rd6c5"))))
+ "1yscj6avirm6m12bjh4fn2lfgxaamqsjh9pirdqfi0fcgq8ils25"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -6559,8 +6559,7 @@ complexity of Python source code.")
("python-mccabe" ,python-mccabe)))
(native-inputs
`(("python-mock" ,python-mock)
- ("python-pytest" ,python-pytest-bootstrap)
- ("python-pytest-runner" ,python-pytest-runner)))
+ ("python-pytest" ,python-pytest-bootstrap)))
(home-page "https://gitlab.com/pycqa/flake8")
(synopsis
"The modular source code checker: pep8, pyflakes and co")