summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-01-29 23:42:36 +0100
committerLudovic Courtès <ludo@gnu.org>2014-01-29 23:42:36 +0100
commitf914963e47baa70ea931c04b7ca348884a41786e (patch)
tree61f5b28d095df1ce9eb45250a1c1786bf445de8e
parent7b99ba4acdbce6d0b134a8bd8eb555d00edeb0a5 (diff)
downloadguix-patches-f914963e47baa70ea931c04b7ca348884a41786e.tar
guix-patches-f914963e47baa70ea931c04b7ca348884a41786e.tar.gz
gnu: linux-libre: Build virtio modules.
* gnu/packages/linux.scm (linux-libre): Build modules matching CONFIG.*VIRTIO.
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b79318f23a..8fe91b4e9f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -163,7 +163,11 @@
(format #t "enabling additional modules...~%")
(substitute* ".config"
(("^# CONFIG_CIFS.*$")
- "CONFIG_CIFS=m\n"))
+ "CONFIG_CIFS=m\n")
+ (("^# CONFIG_([[:graph:]]*)VIRTIO([[:graph:]]*) .*$"
+ _ before after)
+ (string-append "CONFIG_" before "VIRTIO"
+ after "=m\n")))
(zero? (system* "make" "oldconfig")))
;; Call the default `build' phase so `-j' is correctly