summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-03-31 00:30:16 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-03-31 04:06:08 +0200
commitec23833267ac859d3d45f65603e55415475126ba (patch)
tree125ff01e00112ffb1711857699ec7be163028f0d
parent02052b2c9b37af399f36179a8341585b30976650 (diff)
downloadguix-patches-ec23833267ac859d3d45f65603e55415475126ba.tar
guix-patches-ec23833267ac859d3d45f65603e55415475126ba.tar.gz
gnu: hdparm: Use ‘modify-phases’ syntax.
* gnu/packages/linux.scm (hdparm): Use ‘modify-phases’.
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 7a9ecf0a00..f801146cd6 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2283,8 +2283,10 @@ thanks to the use of namespaces.")
(list (string-append "binprefix=" out)
(string-append "manprefix=" out)
"CC=gcc"))
- #:phases (alist-delete 'configure %standard-phases)
- #:tests? #f)) ; no test suite
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)) ; no configure script
+ #:tests? #f)) ; no test suite
(home-page "https://sourceforge.net/projects/hdparm/")
(synopsis "View and tune ATA disk drive parameters")
(description