summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Meyer <mark@ofosos.org>2017-12-15 12:35:38 +0100
committerArun Isaac <arunisaac@systemreboot.net>2020-12-11 11:28:40 +0530
commite530fb41287f8d048643c74fb349bd602abbf3e5 (patch)
tree7f091963d6adb260ab32db228f971eb6f2b00e69
parentd677f3d6231d352fdb65b70f67d85fb5744e912c (diff)
downloadguix-patches-e530fb41287f8d048643c74fb349bd602abbf3e5.tar
guix-patches-e530fb41287f8d048643c74fb349bd602abbf3e5.tar.gz
gnu: Add virtaal.
* gnu/packages/text-editors.scm (virtaal): New variable. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
-rw-r--r--gnu/packages/text-editors.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 878cbb669d..749b93e29f 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2019, 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Tom Zander <tomz@freedommail.ch>
+;;; Copyright © 2020 Mark Meyer <mark@ofosos.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -62,6 +63,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
#:use-module (gnu packages regex)
@@ -1029,3 +1031,42 @@ files. It was originally developed on the Amiga 3000T.")
systems that displays its buffer(s) as a hex dump. The user interface is kept
similar to vi/ex.")
(license license:bsd-3)))
+
+(define-public virtaal
+ (package
+ (name "virtaal")
+ (version "0.7.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/translate/Virtaal/"
+ version "/virtaal-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0cyimjp3191qlmw6n0ipqdr9xr0cq4f6dqvz4rl9q31h6l3kywf9"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2
+ #:use-setuptools? #f
+ #:tests? #f ;; Failing tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Set data file path to absolute store path.
+ (substitute* "virtaal/common/pan_app.py"
+ (("file_discovery\\.get_abs_data_filename.*")
+ (string-append "os.path.join('"
+ (assoc-ref outputs "out")
+ "/share', *path_parts)"))))))))
+ (inputs
+ `(("python2-lxml" ,python2-lxml)
+ ("python2-pygtk" ,python2-pygtk)
+ ("python2-simplejson" ,python2-simplejson)
+ ("python2-translate-toolkit" ,python2-translate-toolkit)
+ ("python2-pycurl" ,python2-pycurl)))
+ (synopsis "Graphical translation tool")
+ (description "Virtaal is a powerful yet simple translation tool with an
+uncluttered user interface. It supports a multitude of translation formats
+provided by the Translate Toolkit, including XLIFF and PO.")
+ (home-page "https://virtaal.translatehouse.org/")
+ (license license:gpl2+)))