summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-29 14:58:44 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-29 17:13:45 +0100
commitc54ab337bcda46f4f9b0c9b4798a853e4d5a85b9 (patch)
tree8a415feee22ac740d24413f91b56db2356889e8f
parent41aab7d186d36876c3ad8202e4d78313235998d3 (diff)
downloadguix-patches-c54ab337bcda46f4f9b0c9b4798a853e4d5a85b9.tar
guix-patches-c54ab337bcda46f4f9b0c9b4798a853e4d5a85b9.tar.gz
gnu: Add r-preseqr.
* gnu/packages/cran.scm (r-preseqr): New variable.
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6a8fda01db..0d498758c5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -13769,3 +13769,29 @@ function for computing a matrix of correlation p-values.")
document to a grid-oriented dashboard. The dashboard flexibly adapts the size
of its components to the containing web page.")
(license license:expat)))
+
+(define-public r-preseqr
+ (package
+ (name "r-preseqr")
+ (version "4.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "preseqR" version))
+ (sha256
+ (base32
+ "1g2rnnmi45649vpy6z45v5i3wxm54s138ajqrzwi3a5r7x3xnhq1"))))
+ (properties `((upstream-name . "preseqR")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-polynom" ,r-polynom)))
+ (home-page "https://cran.r-project.org/web/packages/preseqR/")
+ (synopsis "Predicting species accumulation curves")
+ (description
+ "This package can be used to predict the r-species accumulation
+curve (r-SAC), which is the number of species represented at least r times as
+a function of the sampling effort. When r = 1, the curve is known as the
+species accumulation curve, or the library complexity curve in high-throughput
+genomic sequencing. The package includes both parametric and nonparametric
+methods, as described by Deng C, et al. (2018).")
+ (license license:gpl3)))