summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-11-27 09:50:16 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-11-27 09:50:16 +0100
commitc299102a6b6b616a4f28ef120bef96dadba3ae33 (patch)
tree67b0383a28824990a8701172007c30b9ccb55794
parent99dfe3b2dee39812f1cb41b39754df5caf20c15a (diff)
downloadguix-patches-c299102a6b6b616a4f28ef120bef96dadba3ae33.tar
guix-patches-c299102a6b6b616a4f28ef120bef96dadba3ae33.tar.gz
gnu: emacs-robot-mode: Update to 0.6.1.
* gnu/packages/emacs-xyz.scm (emacs-robot-mode): Update to 0.6.1. [source]: Change URL for a maintained fork. [propagated-inputs]: Remove emacs-s. [home-page]: Update URL.
-rw-r--r--gnu/packages/emacs-xyz.scm43
1 files changed, 20 insertions, 23 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index fcb2302d8f..3ef1527729 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5298,29 +5298,26 @@ method and constant name completion.")
(license license:gpl3+)))
(define-public emacs-robot-mode
- (let ((commit "32846e7e80ae3471b7c07f9709dcaa4f9b9ed4a0")
- (revision "1"))
- (package
- (name "emacs-robot-mode")
- (version (git-version "0.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- ;; A better maintained fork of robot-mode.
- (url "https://github.com/jvalkeejarvi/robot-mode")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1i8wf7m0gml8zvvmlgppjzv78b432686p1qdbzgclc7qfcvzag0d"))))
- (build-system emacs-build-system)
- (propagated-inputs `(("emacs-s" ,emacs-s)))
- (home-page "https://github.com/jvalkeejarvi/robot-mode")
- (synopsis "Emacs mode for Robot Framework")
- (description "This major mode facilitates editing Robot Framework source
-files with features such as syntax highlighting, comments, finding keywords,
-completing keywords and smart indentation.")
- (license license:gpl3+))))
+ (package
+ (name "emacs-robot-mode")
+ (version "0.6.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kopoli/robot-mode")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "127lydk66n90ih39q8gxzb44rss2xllb7bn3ygxrf5m5vvl9w5rj"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/kopoli/robot-mode")
+ (synopsis "Emacs mode for Robot Framework")
+ (description
+ "This major mode facilitates editing Robot Framework source files with
+features such as syntax highlighting, comments, finding keywords, completing
+keywords and smart indentation.")
+ (license license:gpl3+)))
(define-public emacs-roguel-ike
(package