summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-02-09 19:09:35 +0100
committerLudovic Courtès <ludo@gnu.org>2013-02-09 23:21:00 +0100
commitb15fcf9ec2dc95c067a9c3aa810bee86e967145e (patch)
tree890ad681570b76b16f36cfc13d5b9cc2354986cb
parenta69b7ad2d64e0b4db0044f59088e2be278b04e48 (diff)
downloadguix-patches-b15fcf9ec2dc95c067a9c3aa810bee86e967145e.tar
guix-patches-b15fcf9ec2dc95c067a9c3aa810bee86e967145e.tar.gz
gnu: Add QEMU-KVM.
* gnu/packages/qemu.scm: New file. * Makefile.am (MODULES): Add it.
-rw-r--r--Makefile.am1
-rw-r--r--gnu/packages/qemu.scm81
2 files changed, 82 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0de96c8ddd..a7cfbd194f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -124,6 +124,7 @@ MODULES = \
gnu/packages/pkg-config.scm \
gnu/packages/pth.scm \
gnu/packages/python.scm \
+ gnu/packages/qemu.scm \
gnu/packages/readline.scm \
gnu/packages/recutils.scm \
gnu/packages/rsync.scm \
diff --git a/gnu/packages/qemu.scm b/gnu/packages/qemu.scm
new file mode 100644
index 0000000000..e22ffd2fb6
--- /dev/null
+++ b/gnu/packages/qemu.scm
@@ -0,0 +1,81 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages qemu)
+ #:use-module (guix download)
+ #:use-module (guix packages)
+ #:use-module ((guix licenses) #:renamer (symbol-prefix-proc 'license:))
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages ncurses)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages libpng)
+ #:use-module (gnu packages libjpeg)
+ #:use-module (gnu packages attr)
+ #:use-module (gnu packages linux))
+
+(define-public qemu-kvm
+ (package
+ (name "qemu-kvm")
+ (version "1.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/kvm/qemu-kvm/"
+ version "/qemu-kvm-" version ".tar.gz"))
+ (sha256
+ (base32
+ "018vb5nmk2fsm143bs2bl2wirhasd4b10d7jchl32zik4inbk2p9"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (alist-replace
+ 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; The `configure' script doesn't understand some of the
+ ;; GNU options. Thus, add a new phase that's compatible.
+ (let ((out (assoc-ref outputs "out")))
+ (setenv "SHELL" (which "bash"))
+
+ ;; The binaries need to be linked against -lrt.
+ (setenv "LDFLAGS" "-lrt")
+ (zero?
+ (system* "./configure"
+ (string-append "--prefix=" out)))))
+ %standard-phases)))
+ (inputs ; TODO: Add optional inputs.
+ `(;; ("mesa" ,mesa)
+ ;; ("libaio" ,libaio)
+ ("glib" ,glib)
+ ("python" ,python)
+ ("ncurses" ,ncurses)
+ ("libpng" ,libpng)
+ ("libjpeg" ,libjpeg-8)
+ ;; ("vde2" ,vde2)
+ ("util-linux" ,util-linux)
+ ;; ("pciutils" ,pciutils)
+ ("pkg-config" ,pkg-config)
+ ;; ("alsa-lib" ,alsa-lib)
+ ;; ("SDL" ,SDL)
+ ("zlib" ,zlib)
+ ("attr" ,attr)))
+ (home-page "http://www.linux-kvm.org/")
+ (synopsis
+ "A full virtualization solution for Linux on x86 hardware containing virtualization extensions")
+ (description #f)
+ (license #f)))