summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-29 22:41:58 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-30 08:55:46 +0100
commita6e1eb1a96799212815eda7b0408d778b7000022 (patch)
tree07b5be5a43cc77d5e9efd6dee54e1f538060bcf6
parent98a2af31a8066eff780a71a6366749cad5d3d580 (diff)
downloadguix-patches-a6e1eb1a96799212815eda7b0408d778b7000022.tar
guix-patches-a6e1eb1a96799212815eda7b0408d778b7000022.tar.gz
gnu: Add r-roar.
* gnu/packages/bioconductor.scm (r-roar): New variable.
-rw-r--r--gnu/packages/bioconductor.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index b0c1fb08bf..d87d9135ff 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3914,3 +3914,32 @@ normalization. YARN leverages many Bioconductor tools and statistical
techniques to account for the large heterogeneity and sparsity found in very
large RNA-seq experiments.")
(license license:artistic2.0)))
+
+(define-public r-roar
+ (package
+ (name "r-roar")
+ (version "1.18.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "roar" version))
+ (sha256
+ (base32
+ "15650s9vs7dvmqpvrs4xwn6j4kh14yqsx4daqyhhxxr68kn8mklw"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biocgenerics" ,r-biocgenerics)
+ ("r-genomeinfodb" ,r-genomeinfodb)
+ ("r-genomicalignments" ,r-genomicalignments)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-iranges" ,r-iranges)
+ ("r-rtracklayer" ,r-rtracklayer)
+ ("r-s4vectors" ,r-s4vectors)
+ ("r-summarizedexperiment" ,r-summarizedexperiment)))
+ (home-page "https://github.com/vodkatad/roar/")
+ (synopsis "Identify differential APA usage from RNA-seq alignments")
+ (description
+ "This package provides tools for identifying preferential usage of APA
+sites, comparing two biological conditions, starting from known alternative
+sites and alignments obtained from standard RNA-seq experiments.")
+ (license license:gpl3)))