summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-12 13:25:46 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-13 01:20:19 +0200
commit848581ae9b900f0237fc7ab3ab77aa84cd6b2aad (patch)
tree6cc08aa4b47d47567c25c1ac7629e8b15058ffcd
parentec46a5338d60eb6714a47b67e0d1e92079412d73 (diff)
downloadguix-patches-848581ae9b900f0237fc7ab3ab77aa84cd6b2aad.tar
guix-patches-848581ae9b900f0237fc7ab3ab77aa84cd6b2aad.tar.gz
gnu: cpufrequtils: Update to 008.
* gnu/packages/linux.scm (cpufrequtils): Update to 008. [source]: Remove patch. [arguments]: Add many #:configure-flags to mitigate downgrade from Autotools. Don't ./configure. [native-inputs]: Remove unused sysfsutils-1. Add gettext-minimal. [home-page]: Change to a working mirror. * gnu/packages/patches/cpufrequtils-fix-aclocal.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/linux.scm31
-rw-r--r--gnu/packages/patches/cpufrequtils-fix-aclocal.patch46
3 files changed, 23 insertions, 55 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index ea27741a77..c0734c3889 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -954,7 +954,6 @@ dist_patch_DATA = \
%D%/packages/patches/combinatorial-blas-awpm.patch \
%D%/packages/patches/combinatorial-blas-io-fix.patch \
%D%/packages/patches/coreutils-ls.patch \
- %D%/packages/patches/cpufrequtils-fix-aclocal.patch \
%D%/packages/patches/cpuinfo-system-libraries.patch \
%D%/packages/patches/crawl-upgrade-saves.patch \
%D%/packages/patches/crda-optional-gcrypt.patch \
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3f31d24fa2..aa5fbb5bc9 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4780,22 +4780,37 @@ also contains the libsysfs library.")
(define-public cpufrequtils
(package
(name "cpufrequtils")
- (version "0.3")
+ (version "008")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/linux/utils/kernel/cpufreq/"
"cpufrequtils-" version ".tar.gz"))
(sha256
- (base32 "0qfqv7nqmjfr3p0bwrdlxkiqwqr7vmx053cadaa548ybqbghxmvm"))
- (patches (search-patches "cpufrequtils-fix-aclocal.patch"))))
+ (base32 "0xjs8j44hh0cz6qpig1n0iw8xjpr6s5qmcmwh965ngapxgarr7af"))))
(build-system gnu-build-system)
- (native-inputs
- `(("sysfsutils" ,sysfsutils-1)))
(arguments
- '(#:make-flags (list (string-append "LDFLAGS=-Wl,-rpath="
- (assoc-ref %outputs "out") "/lib"))))
- (home-page "https://www.kernel.org/pub/linux/utils/kernel/cpufreq/")
+ `(#:tests? #f ; no test suite
+ #:make-flags
+ (let ((out (assoc-ref %outputs "out")))
+ (list "PROC=false" ; obsoleted by sysfs in Linux 2.6(!)
+ (string-append "CC=" ,(cc-for-target))
+ (string-append "LDFLAGS=-Wl,-rpath=" out "/lib")
+ "INSTALL=install"
+ (string-append "bindir=" out "/bin")
+ (string-append "sbindir=" out "/sbin")
+ (string-append "mandir=" out "/share/man")
+ (string-append "includedir=" out "/include")
+ (string-append "libdir=" out "/lib")
+ (string-append "localedir=" out "/share/locale")
+ (string-append "docdir=" out "/share/doc/" ,name)))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)))) ; no configure script
+ (native-inputs
+ `(("gettext" ,gettext-minimal)))
+ (home-page
+ "http://ftp.be.debian.org/pub/linux/utils/kernel/cpufreq/cpufrequtils.html")
(synopsis "Utilities to get and set CPU frequency on Linux")
(description
"The cpufrequtils suite contains utilities to retrieve CPU frequency
diff --git a/gnu/packages/patches/cpufrequtils-fix-aclocal.patch b/gnu/packages/patches/cpufrequtils-fix-aclocal.patch
deleted file mode 100644
index be5767f462..0000000000
--- a/gnu/packages/patches/cpufrequtils-fix-aclocal.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-Add an extra layer of quoting to ltmain.sh sanity check.
-
---- a/configure 2005-05-07 14:19:31.000000000 +0200
-+++ b/configure 2015-02-10 11:16:32.456146934 +0100
-@@ -6266,7 +6266,7 @@
- exit 1
- fi
- gentoo_lt_version="1.5.16"
--gentoo_ltmain_version=`grep '^[:space:]*VERSION=' $ltmain | sed -e 's|^[:space:]*VERSION=||'`
-+gentoo_ltmain_version=`grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||'`
- if test "$gentoo_lt_version" != "$gentoo_ltmain_version"; then
- echo "$as_me:$LINENO: result: no" >&5
- echo "${ECHO_T}no" >&6
---- a/aclocal.m4 2005-05-07 14:19:25.000000000 +0200
-+++ b/aclocal.m4 2015-02-10 11:16:15.352030318 +0100
-@@ -246,7 +246,7 @@
- exit 1
- fi
- gentoo_lt_version="1.5.16"
--gentoo_ltmain_version=`grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||'`
-+gentoo_ltmain_version=`[grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||']`
- if test "$gentoo_lt_version" != "$gentoo_ltmain_version"; then
- AC_MSG_RESULT(no)
- echo
---- a/libcpufreq/configure 2005-05-07 14:19:31.000000000 +0200
-+++ b/libcpufreq/configure 2015-02-10 11:16:32.456146934 +0100
-@@ -6266,7 +6266,7 @@
- exit 1
- fi
- gentoo_lt_version="1.5.16"
--gentoo_ltmain_version=`grep '^[:space:]*VERSION=' $ltmain | sed -e 's|^[:space:]*VERSION=||'`
-+gentoo_ltmain_version=`grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||'`
- if test "$gentoo_lt_version" != "$gentoo_ltmain_version"; then
- echo "$as_me:$LINENO: result: no" >&5
- echo "${ECHO_T}no" >&6
---- a/libcpufreq/aclocal.m4 2005-05-07 14:19:25.000000000 +0200
-+++ b/libcpufreq/aclocal.m4 2015-02-10 11:16:15.352030318 +0100
-@@ -246,7 +246,7 @@
- exit 1
- fi
- gentoo_lt_version="1.5.16"
--gentoo_ltmain_version=`grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||'`
-+gentoo_ltmain_version=`[grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||']`
- if test "$gentoo_lt_version" != "$gentoo_ltmain_version"; then
- AC_MSG_RESULT(no)
- echo