summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-20 16:28:45 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-20 17:12:25 +0300
commit673bd9a75bd925ba9adf15ac5a07896bc2319fde (patch)
treefd4c05615ee499f4a808491bb22886802bc74074
parentf2af6d371a072047854a28819af43325ba5d08d8 (diff)
downloadguix-patches-673bd9a75bd925ba9adf15ac5a07896bc2319fde.tar
guix-patches-673bd9a75bd925ba9adf15ac5a07896bc2319fde.tar.gz
gnu: Add julia-ifelse.
* gnu/packages/julia-xyz.scm (julia-ifelse): New variable.
-rw-r--r--gnu/packages/julia-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index b8fe48d2ed..4c87adbda8 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -794,6 +794,26 @@ library for parsing HTML.")
implementing both a client and a server.")
(license license:expat)))
+(define-public julia-ifelse
+ (package
+ (name "julia-ifelse")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sciml/ifelse.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1wrw842r8708fryf2ihp9mkmdrg27saa9nix2c31vs995k2fgr9w"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/sciml/ifelse.jl")
+ (synopsis "Function form of the if-else conditional statement")
+ (description "This package provides a convenient function form of the
+conditional ifelse. It is similar to @code{Core.ifelse} but it is extendable.")
+ (license license:expat)))
+
(define-public julia-imagemagick-jll
(package
(name "julia-imagemagick-jll")