summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-12-13 19:21:10 +0100
committerMarius Bakke <marius@gnu.org>2021-12-13 23:28:58 +0100
commit48a6f1d351a0f119ca25ae9b66f535dd2300ac7d (patch)
treef1836b2ded5fa5f7c428191ccf05b8e52002c424
parent99e0c4bc74670f9c25567781a3b243e6145f9406 (diff)
downloadguix-patches-48a6f1d351a0f119ca25ae9b66f535dd2300ac7d.tar
guix-patches-48a6f1d351a0f119ca25ae9b66f535dd2300ac7d.tar.gz
gnu: python-dask: Remove bundled versioneer.
* gnu/packages/python-xyz.scm (python-dask)[source](snippet): New field. [arguments]: Add versioneer phase. [native-inputs]: Add PYTHON-VERSIONEER.
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 72c2809fb4..357aed592f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22350,11 +22350,17 @@ decisions with any given backend.")
(commit "5a8275dd53193b47457cdfadc0e2356ea3eb6ccd")))
(file-name (git-file-name name version))
(sha256
- (base32 "0h8w7c03mn6s2mmwbqd2sqay3k4vaqiwlsbvliziggw28042zfw2"))))
+ (base32 "0h8w7c03mn6s2mmwbqd2sqay3k4vaqiwlsbvliziggw28042zfw2"))
+ (snippet
+ ;; Delete generated copy of python-versioneer. We recreate it below.
+ '(delete-file "versioneer.py"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'versioneer
+ (lambda _
+ (invoke "versioneer" "install")))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests? (invoke "pytest" "-vv")))))))
@@ -22368,7 +22374,8 @@ decisions with any given backend.")
python-toolz
python-pyyaml))
(native-inputs
- (list python-pytest python-pytest-runner python-pytest-rerunfailures))
+ (list python-pytest python-pytest-runner python-pytest-rerunfailures
+ python-versioneer))
(home-page "https://github.com/dask/dask/")
(synopsis "Parallel computing with task scheduling")
(description