summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-29 07:14:17 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-29 07:14:17 +0100
commit45aba232abe50b6642abfaa06030985c7febbe07 (patch)
treec4ee4fd55dfdee1c3b6db21f34e1e373f9947b82
parentd656aea0ef4d96ff530b6e4529f7fb288349c674 (diff)
downloadguix-patches-45aba232abe50b6642abfaa06030985c7febbe07.tar
guix-patches-45aba232abe50b6642abfaa06030985c7febbe07.tar.gz
gnu: stepmania: Fix loading of gtk module.
Fixes <https://bugs.gnu.org/34854>. Suggested by Nicolas Goaziou. * gnu/packages/games.scm (stepmania)[arguments]: Add phase "ensure-gtk-module-can-be-found".
-rw-r--r--gnu/packages/games.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a5ea5cd39a..c7e08f8d98 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -6182,6 +6182,13 @@ civilized than your own.")
"/lib/glib-2.0/include"))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'ensure-gtk-module-can-be-found
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "src/arch/LoadingWindow/LoadingWindow_Gtk.cpp"
+ (("RageFileManagerUtil::sDirOfExecutable \\+ \"/\" \\+ \"GtkModule.so\"")
+ (string-append "\"" (assoc-ref outputs "out")
+ "/share/stepmania/GtkModule.so\"")))
+ #t))
(add-after 'unpack 'fix-install-subdir
;; Installation would be done in "%out/stepmania-X.Y", but we
;; prefer the more common layout "%out/share/stepmania".