summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-04-13 14:21:27 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-06-09 03:31:50 +0200
commit282b01515ba48f17638631c40cfc17e99d4a6cce (patch)
treeccc6f02629673844842b33de9d0ded5acb626e55
parent3420c905cdc37027bd630e9c5f3ac0e6fc066405 (diff)
downloadguix-patches-282b01515ba48f17638631c40cfc17e99d4a6cce.tar
guix-patches-282b01515ba48f17638631c40cfc17e99d4a6cce.tar.gz
gnu: Add phylip.
* gnu/packages/bioinformatics.scm (phylip): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 2844c46075..b7d39ea359 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9389,3 +9389,40 @@ novo exon-skipping events directly from raw RNA-seq data without the prior
knowledge of gene annotation information. GESS stands for the graph-based
exon-skipping scanner detection scheme.")
(license license:bsd-3)))
+
+(define-public phylip
+ (package
+ (name "phylip")
+ (version "3.696")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://evolution.gs.washington.edu/phylip/"
+ "download/phylip-" version ".tar.gz"))
+ (sha256
+ (base32
+ "01jar1rayhr2gba2pgbw49m56rc5z4p5wn3ds0m188hrlln4a2nd"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no check target
+ #:make-flags (list "-f" "Makefile.unx" "install")
+ #:parallel-build? #f ; not supported
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'enter-dir
+ (lambda _ (chdir "src") #t))
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((target (string-append (assoc-ref outputs "out")
+ "/bin")))
+ (mkdir-p target)
+ (for-each (lambda (file)
+ (install-file file target))
+ (find-files "../exe" ".*")))
+ #t)))))
+ (home-page "http://evolution.genetics.washington.edu/phylip/")
+ (synopsis "Tools for inferring phylogenies")
+ (description "PHYLIP (the PHYLogeny Inference Package) is a package of
+programs for inferring phylogenies (evolutionary trees).")
+ (license license:bsd-2)))