summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-06-09 11:56:01 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-06-15 17:03:17 +0200
commitc3455b7d10f5872554c6df2fd765bf7dc4c21cdb (patch)
treedc4b454ce39d580a8a98a828d8dce57d48adbfdb
parent4d660fdf1c14f29156d446ab1e187b238674acfb (diff)
downloadguix-patches-c3455b7d10f5872554c6df2fd765bf7dc4c21cdb.tar
guix-patches-c3455b7d10f5872554c6df2fd765bf7dc4c21cdb.tar.gz
gnu: Add texlive-latex-oberdiek.
* gnu/packages/tex.scm (texlive-latex-oberdiek): New variable.
-rw-r--r--gnu/packages/tex.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 38317501a2..7fbb14274c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -998,6 +998,35 @@ pdf and HTML backends. The package is distributed with the backref and
nameref packages, which make use of the facilities of hyperref.")
(license license:lppl1.3+)))
+(define-public texlive-latex-oberdiek
+ (package
+ (name "texlive-latex-oberdiek")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (texlive-ref "latex" "oberdiek"))
+ (sha256
+ (base32
+ "0aswvsxgsn709xmvpcg50d2xl7vcy1ckdxb9c1cligqqfjjvviqf"))))
+ (build-system texlive-build-system)
+ (arguments
+ '(#:tex-directory "latex/oberdiek"
+ #:phases
+ (modify-phases %standard-phases
+ ;; "ifpdf.ins" is not generated, so we cannot process it.
+ (add-after 'unpack 'do-not-process-ifpdf.ins
+ (lambda _
+ (substitute* "oberdiek.ins"
+ (("\\\\batchinput\\{ifpdf.ins\\}") ""))
+ #t)))))
+ (home-page "http://www.ctan.org/pkg/oberdiek")
+ (synopsis "Bundle of packages submitted by Heiko Oberdiek")
+ (description
+ "The bundle comprises various LaTeX packages, providing among others:
+better accessibility support for PDF files; extensible chemists reaction
+arrows; record information about document class(es) used; and many more.")
+ (license license:lppl1.3+)))
+
(define texlive-texmf
(package
(name "texlive-texmf")