summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Allan Webber <cwebber@dustycloud.org>2016-02-14 12:44:03 -0800
committerChristopher Allan Webber <cwebber@dustycloud.org>2016-02-21 19:01:13 -0800
commit8dfceab779b10fcafb2bbb037f47d2faa4b40288 (patch)
tree29723c9163b98a576b90ce3b85f06eebe4134e92
parent4cb122cd8d81b58d88920ec1c8fb09a72de3db70 (diff)
downloadguix-patches-8dfceab779b10fcafb2bbb037f47d2faa4b40288.tar
guix-patches-8dfceab779b10fcafb2bbb037f47d2faa4b40288.tar.gz
gnu: Add python-amqp.
* gnu/packages/python.scm (python-amqp, python2-amqp): New variables.
-rw-r--r--gnu/packages/python.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 785267dd31..ed3a252ce6 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7897,3 +7897,41 @@ and provides a uniform API regardless of which JSON implementation is used.")
,@(package-arguments anyjson)))
(native-inputs `(("python2-setuptools" ,python2-setuptools)
("python2-nose" ,python2-nose))))))
+
+(define-public python-amqp
+ (package
+ (name "python-amqp")
+ (version "1.4.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "amqp" version))
+ (sha256
+ (base32
+ "06n6q0kxhjnbfz3vn8x9yz09lwmn1xi9d6wxp31h5jbks0b4vsid"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-nose" ,python-nose)
+ ("python-mock" ,python-mock)))
+ (home-page "http://github.com/celery/py-amqp")
+ (synopsis
+ "Low-level AMQP client for Python (fork of amqplib)")
+ (description
+ "This is a fork of amqplib which was originally written by Barry Pederson.
+It is maintained by the Celery project, and used by kombu as a pure python
+alternative when librabbitmq is not available.")
+ (license lgpl2.1+)
+ (properties `((python2-variant . ,(delay python2-amqp))))))
+
+(define-public python2-amqp
+ (let ((amqp (package-with-python2
+ (strip-python2-variant python-amqp))))
+ (package
+ (inherit amqp)
+ (arguments `(;; Tries to run coverage tests with nose-cover3, which seems
+ ;; unmaintained. Weirdly, does not do this on the python 3
+ ;; version?
+ #:tests? #f
+ ,@(package-arguments amqp)))
+ (native-inputs `(("python2-setuptools" ,python2-setuptools)
+ ,@(package-native-inputs amqp))))))