summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-06-09 12:31:03 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-06-15 17:03:18 +0200
commit83fe6231cb7de30ce8c17138938dcd8d77b6336e (patch)
tree7dc43e84323fd06f58c9a80ea21bf4685f577c22
parent93286d385731eba85b2cf44d528b38ccfa3f1319 (diff)
downloadguix-patches-83fe6231cb7de30ce8c17138938dcd8d77b6336e.tar
guix-patches-83fe6231cb7de30ce8c17138938dcd8d77b6336e.tar.gz
gnu: Add texlive-latex-psnfss.
* gnu/packages/tex.scm (texlive-latex-psnfss): New variable.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 17cf78a292..5e9370b386 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1330,6 +1330,30 @@ T2* and X2 encodings. These encodings cover (between them) pretty much every
language that is written in a Cyrillic alphabet.")
(license license:lppl1.3c+)))
+(define-public texlive-latex-psnfss
+ (package
+ (name "texlive-latex-psnfss")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (texlive-ref "latex" "psnfss"))
+ (sha256
+ (base32
+ "1920dcq8613yzprasbg80fh4fcjcidvvl54wkx438nimyxcri7qz"))))
+ (build-system texlive-build-system)
+ (arguments '(#:tex-directory "latex/psnfss"))
+ (home-page "http://www.ctan.org/pkg/psnfss")
+ (synopsis "Font support for common PostScript fonts")
+ (description
+ "The PSNFSS collection includes a set of files that provide a complete
+working setup of the LaTeX font selection scheme (NFSS2) for use with common
+PostScript fonts. It covers the so-called \"Base\" fonts (which are built
+into any Level 2 PostScript printing device and the Ghostscript interpreter)
+and a number of free fonts. It provides font definition files, macros and
+font metrics. The bundle as a whole is part of the LaTeX required set of
+packages.")
+ (license license:lppl1.2+)))
+
(define texlive-texmf
(package
(name "texlive-texmf")