summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Allan Webber <cwebber@dustycloud.org>2016-02-13 20:22:47 -0800
committerChristopher Allan Webber <cwebber@dustycloud.org>2016-02-21 18:59:39 -0800
commit778a284be51d797497701444365d14fa877c1abc (patch)
tree0a8236e2b28c6d6de23c96446a7dbaf0d7ddb5bb
parentae00a41febeb56a6844f982e45e52d6ced62b612 (diff)
downloadguix-patches-778a284be51d797497701444365d14fa877c1abc.tar
guix-patches-778a284be51d797497701444365d14fa877c1abc.tar.gz
gnu: Add python-wsgiproxy2.
* gnu/packages/python.scm (python-wsgiproxy2, python2-wsgiproxy2): New variables.
-rw-r--r--gnu/packages/python.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 76638cb5a7..cad14c189c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7707,3 +7707,40 @@ server with very acceptable performance.")
(inherit (package-with-python2
(strip-python2-variant python-waitress)))
(native-inputs `(("python2-setuptools" ,python2-setuptools)))))
+
+(define-public python-wsgiproxy2
+ (package
+ (name "python-wsgiproxy2")
+ (version "0.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "WSGIProxy2" version ".zip"))
+ (sha256
+ (base32
+ "13kf9bdxrc95y9vriaz0viry3ah11nz4rlrykcfvb8nlqpx3dcm4"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("unzip" ,unzip)
+ ("python-nose" ,python-nose)
+ ("python-coverage" ,python-coverage)))
+ (propagated-inputs
+ `(("python-six" ,python-six)
+ ("python-webob" ,python-webob)))
+ (home-page
+ "https://github.com/gawel/WSGIProxy2/")
+ (synopsis "WSGI Proxy with various http client backends")
+ (description "WSGI turns HTTP requests into WSGI function calls.
+WSGIProxy turns WSGI function calls into HTTP requests.
+It also includes code to sign requests and pass private data,
+and to spawn subprocesses to handle requests.")
+ (license license:expat)
+ (properties `((python2-variant . ,(delay python2-wsgiproxy2))))))
+
+(define-public python2-wsgiproxy2
+ (let ((wsgiproxy2 (package-with-python2
+ (strip-python2-variant python-wsgiproxy2))))
+ (package
+ (inherit wsgiproxy2)
+ (inputs `(("python2-setuptools" ,python2-setuptools)
+ ,@(package-inputs wsgiproxy2))))))