summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-06-09 12:27:43 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-06-15 17:03:17 +0200
commit58308491cb2593cb745689472762d89f2fea1d57 (patch)
tree5dd7ce5a39ff3b5ce7afbc3bf2ba7e4fedc57d36
parentcc09d48bab1982fad4659b9ec1d8fb20250f3bee (diff)
downloadguix-patches-58308491cb2593cb745689472762d89f2fea1d57.tar
guix-patches-58308491cb2593cb745689472762d89f2fea1d57.tar.gz
gnu: Add texlive-latex-fontspec.
* gnu/packages/tex.scm (texlive-latex-fontspec): New variable.
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 06cb4f4371..59e74c9455 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1161,6 +1161,31 @@ programming tools and kernel supĀ­port. Packages provided in this release are:
@end enumerate\n")
(license license:lppl1.3c+)))
+(define-public texlive-latex-fontspec
+ (package
+ (name "texlive-latex-fontspec")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (texlive-ref "latex" "fontspec"))
+ (sha256
+ (base32
+ "1rx43y5xmjqvc27pjdnmqwp4pcw3czcfd6nfpmzc1gnqfl1hlc0q"))))
+ (build-system texlive-build-system)
+ (arguments
+ '(#:tex-directory "latex/fontspec"
+ #:build-targets '("fontspec.dtx")))
+ (inputs
+ `(("texlive-latex-l3kernel" ,texlive-latex-l3kernel)))
+ (home-page "http://www.ctan.org/pkg/fontspec")
+ (synopsis "Advanced font selection in XeLaTeX and LuaLaTeX")
+ (description
+ "Fontspec is a package for XeLaTeX and LuaLaTeX. It provides an
+automatic and unified interface to feature-rich AAT and OpenType fonts through
+the NFSS in LaTeX running on XeTeX or LuaTeX engines. The package requires
+the l3kernel and xparse bundles from the LaTeX 3 development team.")
+ (license license:lppl1.3+)))
+
(define texlive-texmf
(package
(name "texlive-texmf")