summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-06-09 11:51:36 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-06-15 17:03:16 +0200
commit3e485ed2fa0e64b058335d33a6c9e47896a54efd (patch)
tree815cd8dcff67c8c93c5fbec2a539a4f52d3afffe
parent205794c8684076696a3e474a6c9f6d53460b744d (diff)
downloadguix-patches-3e485ed2fa0e64b058335d33a6c9e47896a54efd.tar
guix-patches-3e485ed2fa0e64b058335d33a6c9e47896a54efd.tar.gz
gnu: Add texlive-latex-filecontents.
* gnu/packages/tex.scm (texlive-latex-filecontents): New variable.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index faf949862f..3b14b0f2b5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -807,6 +807,30 @@ with the required packages, constitutes what every LaTeX distribution should
contain.")
(license license:lppl1.3c+))))
+(define-public texlive-latex-filecontents
+ (package
+ (name "texlive-latex-filecontents")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (texlive-ref "latex" "filecontents"))
+ (sha256
+ (base32
+ "0swkbxv8vg0yizadfnvrwjb4cj0pn34v9wm6v7wqq903fdav7k7q"))))
+ (build-system texlive-build-system)
+ (arguments '(#:tex-directory "latex/filecontents"))
+ (home-page "http://www.ctan.org/pkg/filecontents")
+ (synopsis "Extended filecontents and filecontents* environments")
+ (description
+ "LaTeX2e's @code{filecontents} and @code{filecontents*} environments
+enable a LaTeX source file to generate external files as it runs through
+LaTeX. However, there are two limitations of these environments: they refuse
+to overwrite existing files, and they can only be used in the preamble of a
+document. The filecontents package removes these limitations, letting you
+overwrite existing files and letting you use @code{filecontents} /
+@code{filecontents*} anywhere.")
+ (license license:lppl1.3c+)))
+
(define texlive-texmf
(package
(name "texlive-texmf")