summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Allan Webber <cwebber@dustycloud.org>2016-02-15 10:29:08 -0800
committerChristopher Allan Webber <cwebber@dustycloud.org>2016-02-21 19:01:16 -0800
commit0c3b90d47812123cd7d2c7c6129719cfa414481a (patch)
tree2f234c22d84ecc22fccb71af484ee91e701af426
parent97e32948ea59bcc48c2e2595626b87bc463144ad (diff)
downloadguix-patches-0c3b90d47812123cd7d2c7c6129719cfa414481a.tar
guix-patches-0c3b90d47812123cd7d2c7c6129719cfa414481a.tar.gz
gnu: Add python-editor.
* gnu/packages/python.scm (python-editor, python2-editor): New variables.
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index bb800e793f..46d434c363 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8078,3 +8078,31 @@ ISO 8859, etc.).")
(inherit (package-with-python2
(strip-python2-variant python-translitcodec)))
(native-inputs `(("python2-setuptools" ,python2-setuptools)))))
+
+(define-public python-editor
+ (package
+ (name "python-editor")
+ (version "0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python-editor" version))
+ (sha256
+ (base32
+ "1ypnpgvzpkbwsg4rdvy4sy51j28b5xq9v8pnkwxncn07vqz06p7n"))))
+ (build-system python-build-system)
+ (home-page
+ "https://github.com/fmoo/python-editor")
+ (synopsis
+ "Programmatically open an editor, capture the result")
+ (description
+ "python-editor is a library that provides the editor module for
+programmatically interfacing with your system's $EDITOR.")
+ (license asl2.0)
+ (properties `((python2-variant . ,(delay python2-editor))))))
+
+(define-public python2-editor
+ (package
+ (inherit (package-with-python2
+ (strip-python2-variant python-editor)))
+ (inputs `(("python2-setuptools" ,python2-setuptools)))))