summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2020-05-16 22:53:17 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-05-17 15:16:56 +0200
commitf16fa69106c4731a5753660824147c7f7d857395 (patch)
tree6f38081ee078c9ee10dd367fb2e22cbc78f934ad
parentb842c4f5a2c915f04b66bc1c9b382f9209aa644e (diff)
downloadguix-patches-f16fa69106c4731a5753660824147c7f7d857395.tar
guix-patches-f16fa69106c4731a5753660824147c7f7d857395.tar.gz
gnu: julius: Remove unused bundled libraries.
* gnu/packages/games.scm (julius)[source](snippet): Remove ext/{dirent,png,SDL2,zlib}. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/games.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index b729dae63e..177436e6ec 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -987,7 +987,14 @@ automata. The following features are available:
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "01rygr592ar530qv1flmaiq8icl0qdxgc8lhkcdyn1g09941z47v"))))
+ (base32 "01rygr592ar530qv1flmaiq8icl0qdxgc8lhkcdyn1g09941z47v"))
+ ;; Remove unused bundled libraries.
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (with-directory-excursion "ext"
+ (for-each delete-file-recursively '("dirent" "png" "SDL2" "zlib")))
+ #t))))
(build-system cmake-build-system)
(inputs
`(("libpng" ,libpng)
@@ -1001,7 +1008,6 @@ Julius includes some UI enhancements while preserving the logic (including
bugs) of the original game, so that saved games are compatible. This package
does not include game data.")
(license (list license:agpl3
- license:expat ; ext/dirent
license:zlib)))) ; ext/tinyfiledialogs
(define-public meandmyshadow