summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Tropin <andrew@trop.in>2022-02-06 07:58:46 +0300
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-06 23:10:52 +0100
commitc47dc7ffd757d7964d120fd00bce54a007f743e8 (patch)
tree798bd6d6a6a0d90119e1e899bc207323edaff7d1
parent661b5acc723b4271dc75b6c20699601188f16f57 (diff)
downloadguix-patches-c47dc7ffd757d7964d120fd00bce54a007f743e8.tar
guix-patches-c47dc7ffd757d7964d120fd00bce54a007f743e8.tar.gz
gnu: Add emacs-consult-dir.
* gnu/packages/emacs-xyz.scm (emacs-consult-dir): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 74ec1b07d6..81543e1cfc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8381,6 +8381,31 @@ Emacs completion function completing-read, which allows quickly selecting from a
list of candidates.")
(license license:gpl3+)))
+(define-public emacs-consult-dir
+ (package
+ (name "emacs-consult-dir")
+ (version "0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/karthink/consult-dir")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "1cff4ssrn1mw2s5n090pdmwdirnfih8idg5f0ll2bi2djc4hq5kn"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-consult))
+ (home-page "https://github.com/karthink/consult-dir")
+ (synopsis "Insert paths into minibuffer prompts in Emacs")
+ (description "Consult-dir allows you to easily insert directory
+paths into the minibuffer prompt in Emacs.
+
+When using the minibuffer, you can switch---with completion and filtering
+provided by your completion setup---to any directory you’ve visited recently,
+or to a project or bookmarked directory. The minibuffer prompt will be
+replaced with the directory you choose.")
+ (license license:gpl3+)))
+
(define-public emacs-consult-notmuch
(package
(name "emacs-consult-notmuch")