summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-11-07 23:07:45 +0100
committerLudovic Courtès <ludo@gnu.org>2013-11-07 23:07:45 +0100
commit6a9957545ce51e7a50381059d4509d0dfcba0aba (patch)
treea6aafc6921f1800d6f99d413d603638d0a7ae672
parentf9cc897105850dbbf5e12df63e800cb28b0f293f (diff)
downloadguix-patches-6a9957545ce51e7a50381059d4509d0dfcba0aba.tar
guix-patches-6a9957545ce51e7a50381059d4509d0dfcba0aba.tar.gz
gnu: lapack: Use origin snippet to remove the non-free files.
* gnu/packages/maths.scm (lapack): Add 'snippet' field with contents of former 'remove-non-free-files' phase; remove that phase.
-rw-r--r--gnu/packages/maths.scm34
1 files changed, 16 insertions, 18 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 27d83f0f6f..9b2b052a52 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -169,7 +169,16 @@ text, Postscript, PDF or HTML.")
version ".tgz"))
(sha256
(base32
- "1w7sf8888m7fi2kyx1fzgbm22193l8c2d53m8q1ibhvfy6m5v9k0"))))
+ "1w7sf8888m7fi2kyx1fzgbm22193l8c2d53m8q1ibhvfy6m5v9k0"))
+ (snippet
+ ;; Remove non-free files.
+ ;; See <http://icl.cs.utk.edu/lapack-forum/archives/lapack/msg01383.html>.
+ '(for-each (lambda (file)
+ (format #t "removing '~a'~%" file)
+ (delete-file file))
+ '("lapacke/example/example_DGESV_rowmajor.c"
+ "lapacke/example/example_ZGESV_rowmajor.c"
+ "DOCS/psfig.tex")))))
(build-system cmake-build-system)
(home-page "http://www.netlib.org/lapack/")
(inputs `(("fortran" ,gfortran-4.8)
@@ -179,23 +188,12 @@ text, Postscript, PDF or HTML.")
(guix build utils)
(srfi srfi-1))
#:phases (alist-cons-before
- ;; See <http://icl.cs.utk.edu/lapack-forum/archives/lapack/msg01383.html>.
- 'configure 'remove-non-free-files
- (lambda _
- (for-each (lambda (file)
- (begin
- (format #t "removing '~a'~%" file)
- (delete-file file)))
- '("lapacke/example/example_DGESV_rowmajor.c"
- "lapacke/example/example_ZGESV_rowmajor.c"
- "DOCS/psfig.tex")))
- (alist-cons-before
- 'check 'patch-python
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((python (assoc-ref inputs "python")))
- (substitute* "lapack_testing.py"
- (("/usr/bin/env python") python))))
- %standard-phases))))
+ 'check 'patch-python
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((python (assoc-ref inputs "python")))
+ (substitute* "lapack_testing.py"
+ (("/usr/bin/env python") python))))
+ %standard-phases)))
(synopsis "Library for numerical linear algebra")
(description
"LAPACK is a Fortran 90 library for solving the most commonly occurring