summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-02-06 20:40:20 +0100
committerJulien Lepiller <julien@lepiller.eu>2022-02-06 21:42:12 +0100
commit99a9b28806f42362547d086bc2ccd4fc5d03547f (patch)
tree0dd30f28b53fa8ef93f8639b6e5de6d47234295e
parentcceb4d34126208c32f1224af50784cb4408922ea (diff)
downloadguix-patches-99a9b28806f42362547d086bc2ccd4fc5d03547f.tar
guix-patches-99a9b28806f42362547d086bc2ccd4fc5d03547f.tar.gz
gnu: ocaml-integers: Update to 0.6.0.
* gnu/packages/ocaml.scm (ocaml-integers): Update to 0.6.0.
-rw-r--r--gnu/packages/ocaml.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 4a88d17f6c..097a67f20b 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4189,7 +4189,7 @@ sensitive completion, colors, and more.")
(define-public ocaml-integers
(package
(name "ocaml-integers")
- (version "0.5.1")
+ (version "0.6.0")
(home-page "https://github.com/ocamllabs/ocaml-integers")
(source (origin
(method git-fetch)
@@ -4199,10 +4199,12 @@ sensitive completion, colors, and more.")
(file-name (git-file-name name version))
(sha256
(base32
- "0by5pc851fk7ccxqy1w2qc5jwn9z8whyqhs5gxlm5986vr9msnyi"))))
+ "07qk7dgxykn528qvhfwa0j402yr58y1y84ivpi1ji1lvk0qddxcs"))))
(build-system dune-build-system)
(arguments
`(#:tests? #f)) ; no tests
+ (propagated-inputs
+ (list ocaml-stdlib-shims))
(synopsis "Various signed and unsigned integer types for OCaml")
(description "The ocaml-integers library provides a number of 8-, 16-, 32-
and 64-bit signed and unsigned integer types, together with aliases such as