summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-13 18:42:45 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-13 22:41:38 +0100
commitbba4ec62e36a6071d978cdb2e5d267f9bc2068c7 (patch)
tree5ff611be235ef380752c64c32ef2fcc59eacaa33
parent0379a167612f40e525251f4c1b92c9150405af7d (diff)
downloadguix-patches-bba4ec62e36a6071d978cdb2e5d267f9bc2068c7.tar
guix-patches-bba4ec62e36a6071d978cdb2e5d267f9bc2068c7.tar.gz
gnu: Add r-smpracticals.
* gnu/packages/cran.scm (r-smpracticals): New variable.
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 385b97adfc..2de143ca13 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -16630,3 +16630,30 @@ future acute exacerbation in @dfn{Chronic Obstructive Pulmonary
Disease} (COPD) patients, based on the clinical prediction model published in
Adibi et al. (2019) @url{doi:10.1101/651901}.")
(license license:gpl3)))
+
+(define-public r-smpracticals
+ (package
+ (name "r-smpracticals")
+ (version "1.4-3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "SMPracticals" version))
+ (sha256
+ (base32
+ "0zxq84f9i3b86xx6msb25b61gyj9k09iab2b7wg4d93yas9qzayf"))))
+ (properties `((upstream-name . "SMPracticals")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ellipse" ,r-ellipse)
+ ("r-mass" ,r-mass)
+ ("r-nlme" ,r-nlme)
+ ("r-survival" ,r-survival)))
+ (home-page "http://statwww.epfl.ch/davison/SM/")
+ (synopsis "Practicals for use with Davison (2003) Statistical Models")
+ (description
+ "This package contains the datasets and a few functions for use with the
+practicals outlined in Appendix A of the book Statistical Models (Davison,
+2003, Cambridge University Press). The practicals themselves can be found at
+@url{http://statwww.epfl.ch/davison/SM/}.")
+ (license license:gpl2+)))