summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-13 18:51:11 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-13 22:41:39 +0100
commitb441dac7af3f6fbf8b0a7def117abc0181b52f33 (patch)
tree55f12a7e537689c696f210f8aea5a18fa790947a
parentb8d52fe2771220742bf7e55700d0a91e05d8536c (diff)
downloadguix-patches-b441dac7af3f6fbf8b0a7def117abc0181b52f33.tar
guix-patches-b441dac7af3f6fbf8b0a7def117abc0181b52f33.tar.gz
gnu: Add r-ace2fastq.
* gnu/packages/cran.scm (r-ace2fastq): New variable.
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5c530a6a36..4b4d1996b7 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -16860,3 +16860,29 @@ Functions for performing cross validation are also supplied along with basic
prediction and plotting functions. @dfn{Sparse zero variance
discriminant} (SZVD) analysis is also included in the package.")
(license license:gpl2+)))
+
+(define-public r-ace2fastq
+ (package
+ (name "r-ace2fastq")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ace2fastq" version))
+ (sha256
+ (base32
+ "09kk3yyqnr2xp820g0p3aai9a21figigjr9lxkr3zjq2d8gzwfic"))))
+ (properties `((upstream-name . "ace2fastq")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-stringr" ,r-stringr)))
+ (home-page "https://github.com/c5sire/ace2fastq")
+ (synopsis "ACE file to FASTQ converter")
+ (description
+ "The ACE file format is used in genomics to store contigs from sequencing
+machines. This tools converts it into FASTQ format. Both formats contain the
+sequence characters and their corresponding quality information. Unlike the
+FASTQ file, the ACE file stores the quality values numerically. The
+conversion algorithm uses the standard Sanger formula. The package
+facilitates insertion into pipelines, and content inspection.")
+ (license license:gpl3)))