summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-13 18:56:39 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-13 22:41:40 +0100
commita8a7ba9acb5108f710a89e6e79c686ee5979c209 (patch)
tree6e1a1f6f5e59d43dfe98573af30d454fdcb18898
parent43a70edc291de476d705805230f61458de992f70 (diff)
downloadguix-patches-a8a7ba9acb5108f710a89e6e79c686ee5979c209.tar
guix-patches-a8a7ba9acb5108f710a89e6e79c686ee5979c209.tar.gz
gnu: Add r-acfmperiod.
* gnu/packages/cran.scm (r-acfmperiod): New variable.
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8c7fe23667..ece356e7cd 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17022,3 +17022,32 @@ to maximise an approximation to the expectation of the utility function.")
behaviour of the variance components in the classical twin models with respect
to age using B-splines and P-splines.")
(license license:gpl2+)))
+
+(define-public r-acfmperiod
+ (package
+ (name "r-acfmperiod")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "acfMPeriod" version))
+ (sha256
+ (base32
+ "1yww8isfrbs2v9s94hx7p2imyszcgadwafdgpj438n2ik0q6p9d5"))))
+ (properties `((upstream-name . "acfMPeriod")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-mass" ,r-mass)))
+ (home-page "https://cran.r-project.org/web/packages/acfMPeriod/")
+ (synopsis "Estimation of the ACF from the M-periodogram")
+ (description
+ "This package support non-robust and robust computations of the sample
+autocovariance (ACOVF) and sample autocorrelation functions (ACF) of
+univariate and multivariate processes. The methodology consists in reversing
+the diagonalization procedure involving the periodogram or the
+cross-periodogram and the Fourier transform vectors, and, thus, obtaining the
+ACOVF or the ACF as discussed in Fuller (1995)
+@url{doi:10.1002/9780470316917}. The robust version is obtained by fitting
+robust M-regressors to obtain the M-periodogram or M-cross-periodogram as
+discussed in Reisen et al. (2017) @url{doi:10.1016/j.jspi.2017.02.008}.")
+ (license license:gpl2+)))