summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-14 10:57:29 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-14 13:35:57 +0100
commit7dd1fbf9ee14dd534bbd7ce2b629d1a2f6333341 (patch)
tree3495f0d59699d8abfe1635e92c55c0c0f2def500
parent6968aa2fe71a5f5ee63b453d43d3b6d00b1b0f22 (diff)
downloadguix-patches-7dd1fbf9ee14dd534bbd7ce2b629d1a2f6333341.tar
guix-patches-7dd1fbf9ee14dd534bbd7ce2b629d1a2f6333341.tar.gz
gnu: Add r-readbitmap.
* gnu/packages/cran.scm (r-readbitmap): New variable.
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 58d9a7f69f..1699abb85d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -18203,3 +18203,32 @@ used to compute ruin probabilities.")
"This package provides pure R tools to read BMP format images. It is
currently limited to 8 bit greyscale images and 24, 32 bit (A)RGB images.")
(license license:gpl2+)))
+
+(define-public r-readbitmap
+ (package
+ (name "r-readbitmap")
+ (version "0.1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "readbitmap" version))
+ (sha256
+ (base32
+ "14825906l326w59g6apy00j55jg3h5kx2r6s031f4gdkbrc7szbk"))))
+ (properties `((upstream-name . "readbitmap")))
+ (build-system r-build-system)
+ (inputs
+ `(("libjpeg" ,libjpeg)
+ ("libpng" ,libpng)))
+ (propagated-inputs
+ `(("r-bmp" ,r-bmp)
+ ("r-jpeg" ,r-jpeg)
+ ("r-png" ,r-png)
+ ("r-tiff" ,r-tiff)))
+ (home-page "https://github.com/jefferis/readbitmap")
+ (synopsis "Unified interface to read bitmap images (BMP, JPEG, PNG, TIFF)")
+ (description
+ "This package provides tools to identify and read BMP, JPEG, PNG, and
+TIFF format bitmap images. Identification defaults to the use of the magic
+number embedded in the file rather than the file extension.")
+ (license license:gpl2+)))