summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-13 18:50:26 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-13 22:41:39 +0100
commit7199d2a5fcd4db00314086947285bbe3f5ea8fc3 (patch)
tree2a6e36f37c434e6ae6adf44499f80d6ead486ef3
parentc909b710a4ee5021268fc0abbaf324771d6dd63c (diff)
downloadguix-patches-7199d2a5fcd4db00314086947285bbe3f5ea8fc3.tar
guix-patches-7199d2a5fcd4db00314086947285bbe3f5ea8fc3.tar.gz
gnu: Add r-sparselda.
* gnu/packages/cran.scm (r-sparselda): New variable.
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a92a487059..5c0d44ebf7 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -16803,3 +16803,27 @@ data.")
the Elastic-Net and also provides functions for estimating sparse Principal
Components. The Lasso solution paths can be computed by the same function.")
(license license:gpl2+)))
+
+(define-public r-sparselda
+ (package
+ (name "r-sparselda")
+ (version "0.1-9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "sparseLDA" version))
+ (sha256
+ (base32
+ "1k3sw9kc40yxnfss4vrsx34qxmv8ssddyhbfjhxrdldvblhbwchb"))))
+ (properties `((upstream-name . "sparseLDA")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-elasticnet" ,r-elasticnet)
+ ("r-mass" ,r-mass)
+ ("r-mda" ,r-mda)))
+ (home-page "http://www.imm.dtu.dk/~lhc")
+ (synopsis "Sparse discriminant analysis")
+ (description
+ "This package performs sparse linear discriminant analysis for Gaussians
+and mixture of Gaussian models.")
+ (license license:gpl2+)))