summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-14 10:07:26 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-14 13:35:55 +0100
commit70c0dbe73fa099cd7bebccb3bffba3dfe3c3137b (patch)
tree9d8404879204eb1f0c30cc3f710bc31892abd0b0
parent6f0a5ab09819d1237d7434f1565db3016d785c8a (diff)
downloadguix-patches-70c0dbe73fa099cd7bebccb3bffba3dfe3c3137b.tar
guix-patches-70c0dbe73fa099cd7bebccb3bffba3dfe3c3137b.tar.gz
gnu: Add r-gdina.
* gnu/packages/cran.scm (r-gdina): New variable.
-rw-r--r--gnu/packages/cran.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 22e994059b..cb68994565 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17798,3 +17798,43 @@ Algorithm; it is used for optimizing smooth nonlinear objective functions with
constraints. Linear or nonlinear equality and inequality constraints are
allowed.")
(license license:gpl2+)))
+
+(define-public r-gdina
+ (package
+ (name "r-gdina")
+ (version "2.7.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "GDINA" version))
+ (sha256
+ (base32
+ "0875xfbm36gqzr0116xzlbm8rlff85rybr4s4hjzfflfvjdhgvfx"))))
+ (properties `((upstream-name . "GDINA")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-alabama" ,r-alabama)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-mass" ,r-mass)
+ ("r-nloptr" ,r-nloptr)
+ ("r-numderiv" ,r-numderiv)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rcpparmadillo" ,r-rcpparmadillo)
+ ("r-rsolnp" ,r-rsolnp)
+ ("r-shiny" ,r-shiny)
+ ("r-shinydashboard" ,r-shinydashboard)))
+ (home-page "https://github.com/Wenchao-Ma/GDINA")
+ (synopsis "Generalized DINA model framework")
+ (description
+ "This package provides a set of psychometric tools for cognitive
+diagnosis modeling based on the generalized deterministic inputs, noisy and
+gate (G-DINA) model by de la Torre (2011) @url{doi:10.1007/s11336-011-9207-7}
+and its extensions, including the sequential G-DINA model by Ma and de la
+Torre (2016) @url{doi:10.1111/bmsp.12070} for polytomous responses, and the
+polytomous G-DINA model by Chen and de la Torre
+@url{doi:10.1177/0146621613479818} for polytomous attributes. Joint attribute
+distribution can be independent, saturated, higher-order, loglinear smoothed
+or structured. Q-matrix validation, item and model fit statistics, model
+comparison at test and item level and differential item functioning can also
+be conducted. A graphical user interface is also provided.")
+ (license license:gpl3)))