summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-13 18:59:02 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-13 22:41:40 +0100
commit6cc356c3535cd5b16b7a6929903d62beded8e732 (patch)
tree9ebef6f8d8c791b7979d8c94c8651f4f2108caa4
parent3b89a8af7a8cf873b8712aecce7ac1335adb9856 (diff)
downloadguix-patches-6cc356c3535cd5b16b7a6929903d62beded8e732.tar
guix-patches-6cc356c3535cd5b16b7a6929903d62beded8e732.tar.gz
gnu: Add r-gamlss.
* gnu/packages/cran.scm (r-gamlss): New variable.
-rw-r--r--gnu/packages/cran.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 280810f929..ed705145c7 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17072,3 +17072,34 @@ discussed in Reisen et al. (2017) @url{doi:10.1016/j.jspi.2017.02.008}.")
models.")
;; Either version of the license
(license (list license:gpl2 license:gpl3))))
+
+(define-public r-gamlss
+ (package
+ (name "r-gamlss")
+ (version "5.1-5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "gamlss" version))
+ (sha256
+ (base32
+ "0gcngfck0dk2rhjg0z1fnc61dqs0s049jy2rkywaf57531s2k8bc"))))
+ (properties `((upstream-name . "gamlss")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-gamlss-data" ,r-gamlss-data)
+ ("r-gamlss-dist" ,r-gamlss-dist)
+ ("r-mass" ,r-mass)
+ ("r-nlme" ,r-nlme)
+ ("r-survival" ,r-survival)))
+ (home-page "http://www.gamlss.org/")
+ (synopsis "Generalized additive models for location scale and shape")
+ (description
+ "This package provides functions for fitting the generalized additive
+models for location scale and shape introduced by Rigby and
+Stasinopoulos (2005), @url{doi:10.1111/j.1467-9876.2005.00510.x}. The models
+use a distributional regression approach where all the parameters of the
+conditional distribution of the response variable are modelled using
+explanatory variables.")
+ ;; Either version of the license
+ (license (list license:gpl2 license:gpl3))))