summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-14 10:57:13 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-14 13:35:56 +0100
commit6968aa2fe71a5f5ee63b453d43d3b6d00b1b0f22 (patch)
tree201f912d935fca4ba57f0b8c860601803ec48b92
parent7faa05377eda6b7ec5d9292da435f1534285f3dd (diff)
downloadguix-patches-6968aa2fe71a5f5ee63b453d43d3b6d00b1b0f22.tar
guix-patches-6968aa2fe71a5f5ee63b453d43d3b6d00b1b0f22.tar.gz
gnu: Add r-bmp.
* gnu/packages/cran.scm (r-bmp): New variable.
-rw-r--r--gnu/packages/cran.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 1f0ebea2c1..58d9a7f69f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -18183,3 +18183,23 @@ distribution; zero-truncated and zero-modified extensions of the standard
discrete distributions. It also supports phase-type distributions commonly
used to compute ruin probabilities.")
(license license:gpl2+)))
+
+(define-public r-bmp
+ (package
+ (name "r-bmp")
+ (version "0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "bmp" version))
+ (sha256
+ (base32
+ "0jd67r11bn98hjwgyr6gas423787xy7ji2hq7ay80blkkcj91xxx"))))
+ (properties `((upstream-name . "bmp")))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/bmp/")
+ (synopsis "Read Bitmap (BMP) images")
+ (description
+ "This package provides pure R tools to read BMP format images. It is
+currently limited to 8 bit greyscale images and 24, 32 bit (A)RGB images.")
+ (license license:gpl2+)))