summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-14 11:29:56 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-14 13:35:57 +0100
commit5458490ebb2aa5fbb5d72ce8468791669bc634ca (patch)
tree8225cebba57db94a854e5a678ad71a916119b5ef
parent09e9ad334ac15ddea7e440cb1737f2c687f5c43a (diff)
downloadguix-patches-5458490ebb2aa5fbb5d72ce8468791669bc634ca.tar
guix-patches-5458490ebb2aa5fbb5d72ce8468791669bc634ca.tar.gz
gnu: Add r-tolerance.
* gnu/packages/cran.scm (r-tolerance): New variable.
-rw-r--r--gnu/packages/cran.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 855a3c956e..cc0f876d85 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -18375,3 +18375,33 @@ The Hidiroglou-Berthelot (1986) method to search for outliers in ratios of
historical data is implemented as well. When available, survey weights can be
used in outliers detection.")
(license license:gpl2+)))
+
+(define-public r-tolerance
+ (package
+ (name "r-tolerance")
+ (version "1.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "tolerance" version))
+ (sha256
+ (base32
+ "17qh4ad1f3fbcpwlxxqh8qr9bnwjcl4yxk0l3fkbr6b2l4rc5p86"))))
+ (properties `((upstream-name . "tolerance")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-rgl" ,r-rgl)))
+ (home-page "https://cran.r-project.org/web/packages/tolerance/")
+ (synopsis "Statistical tolerance intervals and regions")
+ (description
+ "This package provides functions for estimating tolerance
+limits (intervals) for various univariate distributions (binomial, Cauchy,
+discrete Pareto, exponential, two-parameter exponential, extreme value,
+hypergeometric, Laplace, logistic, negative binomial, negative hypergeometric,
+normal, Pareto, Poisson-Lindley, Poisson, uniform, and Zipf-Mandelbrot),
+Bayesian normal tolerance limits, multivariate normal tolerance regions,
+nonparametric tolerance intervals, tolerance bands for regression
+settings (linear regression, nonlinear regression, nonparametric regression,
+and multivariate regression), and analysis of variance tolerance intervals.
+Visualizations are also available for most of these settings.")
+ (license license:gpl2+)))